DASHBOARD app menu problem

Dear all
I have recently update the firmware of MyCloudEX2ultra to 2.40.157.
I found it having some extra delays accessing/transferring files from PC to NAS, but I decide to wait some time before downgrade it back to 2.40.155.
Some time later, I got the DASHBOARD new notification for OS 5 availability/upgrade and I desided to proceed with this also.
After installation of OS 5 and restart of NAS, I noticed that DASHBOARD Apps menu, does not showing any app, but remains stuck to “LOADING” continuously.
No apps are showing at all. I do not use any DASHBOARD app, but I remember them being available before.
Reading the forum, I discovered that TWONKY (that I used) is now available through DASHBOARD and not directly, as was before.
I am not 100% sure, but I suspect that it could be related with some settings of my router.
Any suggestion to solve it is welcome.

I just discoverd that my streamer is not recognizing the NAS anymore.
This is a disaster for me, as NAS only was used for media storage.

I hope WD to provide ASAP a solution for downgrading to OS 3.

@ika Thanks for reporting the issue with the Apps Screen. Here is the direct link to the Twonky App for EX2 Ultra. You should be able to download to your local computer and install the Twonky App manually on the app screen that you just posted. Please let me know if this also fixes your App Loading… screen issue as well.

https://downloads.mycloud.com/os5-apps/apps/GZA/GZA_MyCloudEX2Ultra/twonky/twonky_8.5.1-2_MyCloudEX2Ultra.bin

Hi SBrown, thanks for your reply.

I downloaded the binary file.
Inside in the DASHBOARD App Store, after I clicked “Install an app manually” an agrrement window appeared, I scrolled down to the end and I pressed “ACCEPT”, but nothing happens after.
The agrrement window remains on screen and I can not install the file downloaded.

@ika Can you check your browser for any Add or Popup Blockers or try a different web browser?
I would also open a Command Prompt on the local computer and check the following network sources for connectivity issues.

ping 8.8.8.8
nslookup download.wdc.com

Dear Samuel
Thanks for your reply.

I removed all adds from Chrome and Opera.
Not any difference.
The same result using native IE-11.

On 1st of November, you send me an email asking between others, if my browser can see the
https://downloads.mycloud.com/os5-apps/apps/GZA/GZA_MyCloudEX2Ultra/GZA_MyCloudEX2Ultra.json

I saved the file as app_info.json and I manually copied in the /var/www/xml folder using WinSCD, according to INCIDENT 201102-001035 instructions.
Copying of the file, solved the problem on my OS5 NAS, but after doing the same on another OS 3 NAS with the same issue (NO AVAILABLE APPS), did not fixed the same problem.

The link provided above, refers to OS5-apps. So I wonder if there is any relevant OS3 link, in case of incompatibility between OS5 & OS3 app_info.json files for apps.

I am sorry, I am just a simple user and I do not know much about networks.

For the last two instructions provided, you may see the results on untitled.jpg

Iakovos Kafetzidakis

Στις Τρί, 17 Νοε 2020 στις 11:21 μ.μ., ο/η SBrown via WD Community <wd@discoursemail.com> έγραψε:

Untitled.jpg

@ika The App menu on OS5 and OS3 pull content from download.wdc.com and your DNS lookup is failing which means the DNS server configured on your NAS and computer cannot resolve download.wdc.com

OS5 uses a JSON and OS3 an XML
This KBA has the links for OS3 XML files.

Hi Samuel

I tried again, but it is not possible to add manually any app from DASHBOARD Apps menu, because the “Add An App agreement screen” sticks after pressing the “ACCEPT” key on the bottom right side and does not forward to any following screen.
I have mentioned it on Nov 1st. Only the “CANCEL” key is responding.

Στις Τετ, 18 Νοε 2020 στις 5:01 μ.μ., ο/η SBrown via WD Community <wd@discoursemail.com> έγραψε:

@ika
download.wdc.com is not resolving on your network and will affect app stores on OS3 and OS5.
Adding the Google DNS server to the My Cloud should resolve that issue for both OS3 and OS5 but not your local computer.

nslookup download.wdc.com
nslookup downoads.wdc.com

Here’s the article that explains how to fix the App Loading issues for OS 5