Dashboard and Public Share Icons took a dump

my cloud mirror worked fine yesterday.

just tried to access it now, and was unable to access from either of two laptops either the public share icon or the dashboard icon.

I can see all my files from the admin function (wd my cloud icon) but clicking on the other two icons produce the same message - windows cannot access … after clicking on diagnose I get "your computer appears to be correctly configured but the device or resource is not responding

There are perhaps a couple of things here that may have gone wrong. Do your icons refer to the MCM via its IP address, or its name?

If by name, have you changed that name under the dashboard? For example if you started with the MCM named “WDMyCloudMirror” it would be accessed via \WDMYCLOUDMIRROR over your local network, but if you change the name on the dashboard (for example to “MyNAS”) then the access will similarly change to \MYNAS.

The other possibility is if you have the IP address of the MCM being handled via your router using DHCP and you have rebooted the router, then it may have assigned your MCM a different IP address and so if the IP address is set in the icon links, they will now be pointing at the wrong address and so won’t be able to access the MCM.

The latter is more common/likely, and is easily fixed by either assigning a fixed IP address in your DHCP table in your router set-up, or using a static IP address set-up on the MCM itself.

1 Like

First off - thanks so very much to responding to my post.

Not sure if the problem ocurrred and then I reset the router, or if I reset the router first.  Regardless, I have reset the router several times in my feeble and uneducated attempt to solve this issue.

Your post really explained so much in a just a couple of sentences so thank you again.  i have found the DHCP setting on my router table, but have not been successful getting what I thought was the IP address of the MCM to be assigned in the table.  (I continue to get an invalid data message).  I can continue to try that, but there are multple lines Static DNS1, Static DNS2, WINS.  I am running windows 8.1 and a Cisco router if that helps

How difficult is it to assign a static IP address on the MCM?  Then would i need to do something more on the router side?

Again, thanks so much for taking the time to respond and explain what I believe to be clearly a contributing factor

It’s not too difficult, but it does need a little work on the MCM and on your router (or whatever on your network is acting as the DHCP server and supplying the IP addresses for the network).

On the MCM:

  • Log into the dashboard and select the settings menu from the bar at the top (the right hand icon, after scrolling).
  • On the menu that appears on the lower-left, select Network (the second option from the top).
  • The first item in the list that will appear on the right hand side is the one you want (IPv4 network mode).
  • This will almost certainly be set to “DHCP”, you need to select “Static” and then “Configure >>” just to the right of it.
  • Here you will need to enter the information for the static IP that you want to assign to your MCM.
  • IP Address - the address you want to assign to your MCM. Make this something nice and high in the range (mine at home is set to
  • Subnet mask - this is usually
  • Gateway IP address - this is usually the IP address of your router, often or
  • DNS server - again usually the IP address of your router, or if you prefer you can have it go to another server like Google’s on or

On your router:

  • You need to find where the range of available addresses is defined for the DHCP server, and set it so that the upper limit on the address space is less than the IP address you gave to your MCM. On mine I’ve set it to be between and (where is the router itself, and I’ve left up to available for static addresses).

Alternatively you may be able to assign a fixed IP address in the DHCP settings of the router itself, at which point you don’t need to touch the MCM (the MCM will dynamically get its IP address details from the router, but you set the router to always assign the MCM the same address). It’s technically not quite the same as a static address, but the end results are the same in that the MCM will always be found on the same IP address on your network. How this is done will vary from router to router, so there I can’t help much with specifics.

Basically what you are trying to do is ensure that the static address you’ve assigned the MCM is outside the pool of addresses that the router may assign by DHCP. You do not want two devices with the same IP address on your network, as it will cause all sorts of issues for routing of packets etc. If you set the MCM’s static address nice and high then the chances of clashing are minimal, but to do it fully correctly you need to limit the upper end of the pool of available addresses so that the MCM’s new static address is not available for DHCP assignment.

See page 112 of the MCM user manual for more details and screenshots.

But what I would do first is look on your router and see what IP address your MCM is currently assigned to, and then look at the properties of the icons that are not working and see if they are referring to the MCM via an IP address, and whether that IP address is the same as the current one or not.

1 Like

Thank you again for taking your time to help.

In order to begin taking the steps you outlined, you indicated go to the MCM dashboard.

With the MCM dashboard or Public share icon not working how else can I access the dashboard? 

I went into the program files but cannot seem to locate either of the .exe for the shortcut for those icons.  The odd thing (and I mentioned this in my original post) is that I can see the all my stored files from the WD My Cloud Icon (as well as having access to the Learning Center) just cannot access them in any way … and again have no access to the MCM dashboard or MCM public share. 

It is almost like each of these have been deleted from the program files … or else I just do not know exactly how to find them.

Thanks for your continued help and patience, I know enough technology to get the cloud set up and it was working beautifully.  The downside is, when something like this happens I have no clue where to begin to rectify the issue.

To access your dashboard, there are two things you can try:

If you have Quickview installed, right click on it, select the MCM entry on the list and select Dashboard from the sub-menu that will appear.

Alternatively log into your router, and see what IP address your MCM is currently assigned to. Enter that IP address into IE (or your web browser of choice) and it should take you to the MCM dashboard.

1 Like

I actually had a little breakthrough.

I found another table in my cisco router settings and the MCM was not listed.  All the balance of the pcs, and phones on the network show up … but no MCM.  Not sure how it does not show up.

I attempted to manually “add the client” (MCM) using the name, the original IP and MAC address that I had jotted down before.  It was successfully added with the correct IP and MAC address now displayed as a “client already resevered”

Just tried the icons again after adding what I believe is the orignal IT address and no luck.

I am always leary of reinstalling things multiple times, i think that is often the point of last resort as it messes up other things, but do you think it makes sense to reinstall the MCM dashboard and public share.  Seems like a lot of execss duplicate files.

Again, thanks so much for taking so much of your time to help … I really feel like we are getting closer.

sorry, meant to also address your first point.  I got jazzed after finding the place to add a device.

I did see a Quickview folder as you suggested at the top of the previous post, but nothing in the folder that allowed me access the dashboard.  I would love to be able to get to the dashboard.

Many thanks

If it’s installed, then WD Quickview should run with Windows start-up (there’s no need to run anything). Look in your system tray and see if you can find the icon there, and if so mouse-over it and right click to get the menu I referred to before.

For your icons, check the properties of them and see where they are actually pointing at (IP address or name) and then once you have access to the dashboard then check that what is in the icon matches what is on the machine - my expectation is that it will not and that is the root of your issue.

1 Like

Wow … and I mean wow.

I was just about to uninstall and reinstall the software when my wife suggested to try one more time … and as if by a St. Patricks day miracle (today is 3/17) it has come back from the dead.

All I can think is the router got reset and based on your excellent diagnosis, i have successfully (and being totally honest, not really sure how) added the IP and MAC address back into the router.  It looks like it took a day to work or perhaps a reboot of another piece of software.

Soooo, while I am very nervous that it will happen again, and will want to research on how to harden this sequence.

I am marking this as resolved.

For any other neophytes picking up this thread the key is in the router and if that gets reset you need to make sure it still matches … that and hope you get DarrenHill to look at your post.  You have been incredibly helpful and exceedingly patient to someone who is non technical … and for that you have my thanks.  You sir are indeed a MOST respected and appreciated contributor

You’re welcome, glad it’s working now. If you like, you can click the star icon on the left hand side of my posts to give Kudos for the answers.

As to securing things for the future, the best way is to fix the IP address of the MCM using one of the methods I described above. That way the IP address shouldn’t go walkabout again, and thus things should be more stable. Either that or adjust the properties of the icons etc to refer to the MCM via its name rather than its IP address, that way (presuming you don’t go renaming the MCM) the IP address won’t matter as your PC will ask your router to resolve the name into the IP address anyway, so all accesses will get routed to the correct current IP address anyway.

Oh and always listen to suggestions from your wife - it may not help the problem but it’s the secret to a long and happy life, or at least a quiet one :wink:

1 Like