Dashboard Access viaQuick View


I have just had my My Book Live Duo replaced with 4TB Cycloid Mirror after the duo started to fail.

I have eventually managed to set the drive up how I had it before and have transferred all my files on to the new drives from a back up.The firmware for the Mycloud Mirror is up to date and after putting nearly 2TB of files on to the drive I shut the entire system down (drive, Airport Extreme, modem and Macbook) left it for 20 minutes and then re-booted everything.

I have a Macbook running the latest version of El Capitan and I re-installed the WD Quick View app.
The app finds the drive , temperature and condition fine. However when I click on Dashboard from the app the web browser opens and try to access xxxxxx.local (xxxxxx being the name I gave the drive when I set it up). I then get a “404 Not Found The requested URL /UI was not found on this server.”

This is clearly wrong. The Quickview App shows the drive with a green status light. The drive is in Finder and I can access all the files from there.

I can access the dashboard from using the IP address but can’t understand why I can not access it from the Quick View app.

Any ideas?


Hi, what is your default web browser? Can you change your default browser and see if it works?


My default browser is Safari.

I changed it to Chrome and Firefox, same result.

Hi, if you are able to access the drive using the IP and no other Browser works, most likely the DNS is not resolving the drive name correctly. I would try to restart bonjour or make sure that is running but on “El Capitan” I am not sure how is done.

Just an update

Not sure how but I now have this worming using Firefox.

Still doesn’t work on Chrome or Safari