D-Link router or My Book World 1TB?


#1

I just bought the 1TB World Edition and finally got it up and running.  I plugged it directly into an open port on my D-Link DIR-615 router.  Ever since then, the router loses internet communication with ComCast.  I reboot the router and all is fine for a day or so then it drops off again.  The Router is not showing any problems in it slog.  I have taken the WD Drive off the network for a couple of days to see if it continues.

Also, I run the McAfee Security Center suite on all of my computers.

Any suggestions?

Thanks


#2

I have had similar issues.  I purchased new laptop, new hard drive and new router…my first WD external hardrive was “broken” so the shop offered me a replacement, instead I upgraded to the World 1 TB.

This drive did not want to work with the Belkin Play router and I had been advised by the shop’s pc support staff to try and install the hardrive directly to the laptop before trying the router again.  This ensured that I was literally kicked off the internet (ComCast as well).  The pc mistook whatever the WD software had done as another modem/router and internet connection.  I could not figure out how to uninstall the software and I could NOT connect to the internet at all. 

The shop suggested that I replace the router with a Netgear Wirless N-Gear 300.  This finally worked as the Netgear installation process allowed me to remove the WD created “modem”.  Had to plug in the hardrive into the laptop and follow the instructions but it worked!

The drive is now plugged into the back of the Netgear router. I am now trying to see how I can ensure this stays stable as I really don’t want to have to worry about this drive any more!

I’m running Windows 7 with Kaspersky anti-virus.

Any help will be appreciated!

Thank you.