Current Firmware?

So I noticed a mention of a WD Media server from a 2.x update, however my current firmware is 1.01.03, and no updates show available. I couldn’t seem to find a chart saying if my specific model ( The 3TB My Book Live) uses only the 1.x or if I have the ability to go to the 2.x? I found the “gpl-source-mybooklive-02.43.03-022” zip file from the firmware listing, but found no installer .Deb to update manually. Hoping this is a simple answer. Any help is appreciated. :smiley:

So when you try to update from the Web User Interface, it says there’s no update available?

There’s been 17 firmware updates since 1.01.03.  

See this for more info:

Correct, always says up to date. The response I get from each of those topics relating to updating manually is :

“The _ My Book Live  and  My Book Live Duo  have firmware which can be updated through the  Dashboard _. For instructions on how to update the firmware, please select the method you would like to use in the table below:”

All Dashboard methods lead me to checking for updates, and don’t have the option to do an update. I downloaded the WD Media Server .deb file and updated using it, though now my Media server is just broken… t_t… So I need to be pointed to a current version of a .deb update file to manually do the 2.x update, else an explaination on how to complie the GPL Source code into a .deb :

That’s all I can find so far.

 I should also note: I’ve already tried a factory reset. Still no luck.

see if this help, it is a bit old but it might still apply. As stated, you might need to do a couple of versions before the final one.

I would check with tech support, unless someone here knows for sure.

Also, make sure you have backups in case of disaster.

In the proccess of backing up to an old Time Machine which will likely take most of the night. If anyone has a suggestion on Incremental updates in between 1.x and 2.x that’d be amazing, but that post is perfect! Unless someone says otherwise I plan to flash the latest 2.x .deb tomorrow.

Any offical word on needing an incremental patch before jumping right to the latest one?

Definitely DO NOT try to go directly.  

If I were you, I would do each and every one step at a time.

After each, try an update via the Web dashboard, and let it do whatever it does.

If it says No Update, then manually do the next one.

…and repeat.

And MAKE SURE you read the release notes first!   There have been a *LOT* of changes since launch – some may undo things you need, like MioNet, for example.

So here I am… I got to update … By Auto-Updating, Only having to manual the first patch after my firmware. It stalled a bit, errored a few times, but finally ‘Went through’… Only to show now an infinite “Initializing device. Please Wait…” No matter how long I wait. The light is a Pale Orange-Green. Since it has no USB port, I can’t do a manual update through that, nor is SSH enabled anymore. If I attempt to go to the SSH Url I get to a CakePHP Error. I’m so lost. Can anyone tell me something to try? 

EDIT: I can still SSH with a terminal, just not the SSH UI. So, give me some Linux instructions.

So, I’m at a loss here. Whatever decided to occur, I am now unable to access SSH either. Always gets connection refused. Is it possible to connect it by ethernet and do a manual upgrade? The UI only loads to Initializing, and the SSH always says connection refused. I somehow got the .deb file onto the public folder, but can’t make it do anything. Halp.

This is old, not sure if it can be any help, you do need ssh though.

And last, or at least the last option I know of…

Alright, so, I became boy wonder for a few minutes. After a full day of trying random methods to connect to this thing, I finally decided to break the MBL Web page. So I loaded up the MyBookLive page, using the inspect element option for Chrome, I unloaded the ‘Initializing Please wait…’ Banners, using the delete key to delete the code from the page through the inspect window. This was amazing, as it allowed me access to the UI. Through this I was able to get to the update page, and chose the newer file to do a new firmware upgrade. Success! It then updated all the way to 02.43.03-022! All through the automatic update system. Amazing! I finally got it! Now we’re all up and running, and going just fine. :smiley: Thanks for the help guys. (And SO glad I didn’t have to break the thing open to restore it).

This information could be useful for others as a De-brick method depending on their issue. :smiley:

1 Like

Now, I’ve noticed a drastic slow down after all this. Literally takes minutes sometimes to move from one part of the Web UI to another, much less anything else. Could something have been modified by the update to affect speeds? I’ve seen several posts but no solutions.

After jumping through all those hoops, I’d recommend you do a system restore on the drive and start from scratch.

Yes, you will need to get your data off the drive first.