Ctorrent stuck on connecting to peers

I have a WD ShareSpace 8TB with 2.2.93 firmware. Recently the Ctorrent software stopped working for the majority of the torrent files. The loaded files just hang in the list, status ‘Incomplete_and_Downloading/Uploading_(peer)’. Checking more in details it seems it is retrieving the peers, but nothing happens, even after waiting several days. The folder is created on the drive with the files in it, which of course do not work. The TCP port 2106-2706 are forwarded to the unit. I also tested the torrent files with Trasmission on a iMac and they work fine, the client starts the download immediately.

Anybody knows how to get this fixed? I contacted WD Support, but have not got back to me yet.

What if you delete the torrents and load them again?

I already tried, nothing. No solution so far. Technical support suggested me to do many other things, including a soft reset. Nothing helped. The unit works fine apart from this annoying Ctorrent problem…

Guys and developers,

I found the problem. The Ctorrent included in the WD ShareSpace supports only http trackers and not udp ones. Whenever a torrent file has also udp trackers in it, Ctorrent gets stuck in ‘connecting to tracker’ status. Easy way out from this problem is to edit the torrent files (e.g. torrenteditor.com) and remove the udp trackers. Done that, Ctorrent will work fine again.

It would be of course great as long term solution, if the developers could enable the support to udp trackers in the embedded Ctorrent. Based on my reasearch Ctorrent as such should support also udp trackers.

The above has been found and fixed as described also with the latest firmware 2.3.01.

 Still a problem on my wdsharespce and it has the latest latest firmware 2.3.01 :frowning:

Have you tried to edit the torrent files and remove the upd trackers? this solved the problem for me. Ctorrent works fine with this little trick, although it is a bit annoying. I hope the developers will release and update to support udp trackers soon…

WD developers, any plan to add udp tracker support to Ctorrent?

It is clear ctorrent does not support udp tracker, which is absurd. I am sure I am not the only one with this problem… and not a single reply from WD… I am speechless…