CRYING FOR HELP! My cloud home 4TB is DEAD!

I bought this device for my wife this Feb, she’s a photographer(wedding/realty/landscape). It was fine and she uses this device occasionally. This week she told me she could not connect to it and needed to get some of her previous works.
Then I found the front white light was blinking all the time(in a very fast speed, faster than the “fast breathing” even). I restarted no luck. Login to my router, the device is not shown up at all. Switched cable/router, no luck. Wait for more than 48 hours of blinking, no luck.

I contacted the support, they suggested me to either do a factory reset or replace, but they all are not acceptable to us.

I wonder if someone here has the knowledge to at least get all my wife’s photo out of it. Then I can throw it away.

I want to teardown the case and plugin to some pc, I did see someone said it’s using a specific fs(KDDFS), you could not easily read files from it. but you could use dd to dump imgs back to the device to restore.

The other thing comes to my mind is it may be caused by electrical blackout(we do have several strong wind last few months), it might be just in a weird fsck state, if we could have a monitor/keyboard connect to the internal debian, we might be able to do something to it.

WD used to be a very reliable brand to me since I was little, but I got so disappointed this time, could not believe how their quality becomes so bad nowadays and they do not concern about user’s data at all.

Hi Duke, I saw your cry for help, and I can suggest a couple of things, but you seem reasonably technical.

  • First, there are a few different levels of ‘reset’ - the lowest level just changes all the user account settings and password for admin, but leaves the data on the disk. e.g. this story… and this one

  • Have you tried connecting to a PC via the USB3 port? If you are ‘lucky’, the network port is fried but that’s all, and the board OS is still operative. Get your data somewhere safe, then get WD to replace it.

  • Did you have it backing up to the WD Cloud service? Are your photos there, maybe?

  • If those are no good, the next thing I would want to try is getting the hard disk out of the unit and connecting it to a machine to see if its still working. This is warranty-voiding if you do it yourself, yet it might be worth doing if you really need the data. From what I’ve read, its very difficult to non-destructively disassemble, but not impossible.

  • If the hard disk inside the MyCloud is dead, your next step is professional help from people who can do things like replace the drive circuit board, which is likely to be expensive and not guaranteed to work.

(I’m surprised WD are not able to work with you a bit more - might be worth calling them back to see if you can negotiate a pathway where you take it to a local tech who destructively tries to rescue your data, and they send you a replacement.)

Best of luck. Sometimes hardware failure causes real losses. I hope that hasn’t happened to you.

I am experiencing the same problem but am not quite as technically savvy. I had been transferring data (mostly photos from the last 10 years) from my MacBook Pro to the 4TB WD drive. We recently moved and upon plugging the WD drive in again it is fast blinking. During the last year I’ve had spotty online back up for various reasons so I’m very worried I’ve permanently lost irreplaceable photos of my family. I am not sure what to do.

Thanks for the advice. I have tried a 28sec reset which they claim will have no harm to the data, but still no luck. Also I tried with direct usb connection, not working. No more backups, we actually found my wife’s original hd was turning slow, so that’s why she copied all photos there to this device and then reformat the original disk already.

I have contacted their level II support, he asked me to directly connect the ethernet to my computer, we found there was a weird IP on the device. We can ping it, but both default http port(80) and ssh(22) do not work. Later I used a port scanning software found there are three ports on the device (9090/50001/55964), the 55964 seems to be a http port, because I got some text returns “GET / does not support”. Not sure if anyone knows if I could do something about these ports.

The WD support team is still looking for solutions, potentially will send it to a data recovery company for me. Not sure yet.

You can also try to call the warranty support if your device is still under coverage(partial). Hope your issue is better than mine, because their support team tried everything they could so far, the answer I got is the box is dead.

I just do not understand why they don’t even try to repair it. My case is the control port is still alive with some random ip and several ports are open indicate the startup was partially successful. It might just hang or fail several other crucial services on the startup, should not be hard to fix if they can have access to see what’s really going on inside.

Had the same issue.
Slow Blinking LED and no access to data using Mobile App, Web App or WD Discovery.
However, I did have access to the //MyCloud-XXXX/Public Samba share from Windows 10.
Tech support told me that since I can access the Public Share, the internal HDD cannot be dead because there’s only one. I took MCH to my GF place, connected to her router and WAMMO!!!
Took it back home and NADA!

Scanning the ports and here’s what I can gather thus far

Service Details
Port 81 (TCP) lighttpd 1.4.33
Port 139 (TCP) Samba smbd 3.X - 4.X workgroup: WORKGROUP
Port 443 (TCP) MCH Internal SSL Port (i’m sure)
Port 445 (TCP) Samba smbd 3.X - 4.X workgroup: WORKGROUP
Port 548 (TCP) AFP (Apple File Protocol)
Port 4010 (TCP) Social Media and Cloud Import
Port 8089 (TCP) Tunnel is ssl: unknown service
Port 9999 (TCP) ???
Port 10818 (TCP) Channels DVR Service
Port 21304 (TCP) Amazon Alexa
Port 22546 (TCP) ???
Port 24744 (TCP) Sonos
Port 32400 (TCP) Plex Media Server httpd
Port 33284 (TCP) ???
Port 41012 (TCP) Plex Connect
Port 50746 (TCP) IFTTT

I’m guessing that since I have the exact same issue at home, but not at my GF, and the port scan is done from my home, the device is working fine, but I just cannot access the login space.

1 Like