Credentials Error using My Book Duo connected to Mac Mini as Safepoint for My Book Live

I have set up a My Book Duo on my Mac mini to try and use it as a Safepoint for my other My Book Live. It is connected via USB and I have File Sharing turned on to allow SMB and AFP sharing of the My Book Duo drive (and also a few other folders on my mac mini)

When I go into the My Book Live web interface and start to create the new Safepoint, it sees the Mac mini just fine. However, when I click on it to choose a location it immediately (prior to showing any folders) asks for Device Access username and password. No matter what I put in here it always gives a 35104 invalid username or password error.

I have tried everything I can think of on the Mac mini to make sure the username and password are valid.

  • I’ve enabled Guest access of shared files, which I thought would mean no username/password but the web interface always asks for one and gives an error if I leave both fields blank. I also tried just putting in ‘Guest’ or ‘guest’ as the username and no password, which didn’t work.
  • I’ve enabled the root user on the Mac mini and tried to log in with that user.
  • I’ve made sure the File Share allows Read/Write by everyone, by my specific user, by admin groups, and then tried logging in with the credentials for my user.
  • I even created a new user on the mac mini and gave that user full read/write to that folder

Am I missing something for what credentials it is asking for? Any help would be appreciated!

Does this only happen with your Mac? Have you tried other storage devices within your network?

So far it is only on the Mac. I used to have this exact same My Book Duo
USB drive hooked up to an Asus router (rt-ac68r) and I was able to use it
as a safepoint.