Creating USB Recovery Stick for DX4000

I’m trying to create a USB recovery stick for my DX4000 (it won’t boot), using the ISO Recovery image I downloaded from your site.  When running the recovery software, I’m using the third (or last) option “Perform a Recovery”. When I get to the dialog box asking to select the USB drive, there is no USB drive listed.  Clicking “Refresh” does not discover the USB drive.  I can see the USB drive just fine in file explorer and diskpart.  I’ve read KB 9889 which denotes the USB drive requirements (nice, BTW, for clearly documenting that in the recovery wizard :frowning: ). I have a SanDisk Cruzer 16GB USB 2.0, SDCZ36-016G, which meets your criteria, but no matter what I try, I cannot get the recovery wizard to “discover” this USB drive.  

Things I’ve tried:  

  1. Removing and re-inserting the USB drive in the client PC; 
  2. Shutting down the recovery wizard and restarting with the USB stick still mounted.
  3. Shutting down the recovery wizard and restarting and then inserting the USB stick.
  4. Rebooting the client PC with the USB stick still mounted and then restarting the recovery wizard.
  5. Using Diskpart to reformat the USB stick as a bootable NTFS partition.

I’m running Windows 7 Pro SP1 x64 on my client machine.  I have a HP Pavillion dv7-1024us with 8GB of RAM.  I’m at a total loss of what to do… suggestions?  My DX4000 is a critical resource on my network.

It is pickey I agree.  I am using a 32gb  USB 3.0.  Not at that compter now, but I think it was kingston. I know that KB also says not usb 3.0

Only thing I know to do is try a different usb brand/stick

found it.  This is whhat I got

But I bought it 5/12/2012   so they may have changed?


I’m running into the exact same problem as the OP, namely that the recovery software doesn’t detect any of my USB drives even though they meet the requirements stated in KB 9889. I’ve also confirmed the ISO file has the correct md5 hash.

Can anyone else confirm successfully creating a server recovery USB using the PANAM_SvrRecovery_1_7_5_17.iso file (md5: 4fa4adb74253b3662b4ec0ccfeeb7112)?

What other flash drives have people used successfully? The flash drive Gramps linked to is now rare and overpriced. Currently there’s only one available from a 3rd party seller on Amazon and it’s priced over $100. There’s apparently a newer model of the same product, so maybe that’s worth a try… I’d prefer not to aimlessly hunt for a needle in the haystack.

In case anyone else is digging into this too, I noticed that after clicking the refresh button which checks for connected flash drives the following is appended to a log file (%TEMP%\Windows Server\Logs\FormatDisk.log). I imagine “Repacking disk array with 0 disks” would be more promising when drives are detected.

[11/16/2014 11:01:43 1164] UsbBoot: ------------------------
[11/16/2014 11:01:43 1164] UsbBoot: GetRemovableDisks called
[11/16/2014 11:01:43 1164] UsbBoot: Creating disk util instance
[11/16/2014 11:01:44 1164] UsbBoot: Fetching all removable disks
[11/16/2014 11:01:44 1164] UsbBoot: Allocating new disk array
[11/16/2014 11:01:44 1164] UsbBoot: Repackaging disk array with 0 disks
[11/16/2014 11:01:44 1164] UsbBoot: calling back...
[11/16/2014 11:01:44 1164] UsbBoot: Freeing disk info
[11/16/2014 11:01:44 1164] UsbBoot: Deleting allocated disks
[11/16/2014 11:01:44 1164] UsbBoot: Deleting disk util

It’s unfortunate that KB 9889 imposes so many constraints, but doesn’t list any drives that are known to work. I already had a 32GB flash drive that didn’t work and bought a 16GB today that didn’t work. Both drives work fine otherwise; nothing seems wrong with them. If I can’t get the recovery tool working, this DX4000 is as good as a doorstop. Thanks in advance!

No clue myself without trial and error like you say, but I would like to try one that did not work.  Have you got a link for the 16gb that did not work for you?


1 Like

I totally forgot to reply to Gramps suggestion.  I ordered the newer version of his suggested USB stick and it worked!  I have permanently marked that precious USB stick as my recovery stick for my DX4000.  It is very frustrating that WD doesn’t know what is precisely required to perform a recovery on one of their boxes.  I don’t understand what is so difficult about writing software that will accept any USB stick with minimum restrictions (like capacity).

My total experience with the DX4000 has totally soured my experience with headless NAS boxes.  I am now building my own NAS box with VGA support.  It is essential to see what is happening during POST, when you are having issues booting.  I will probably gut the drives out the DX4000 and use them in my new box.

Ok, done venting… Thanks again Gramps your suggestion did work and I was able to recovery my box.

1 Like

Thanks for your help, Gramps.

The 16GB model that didn’t work was a Sandisk Cruzer Glide (UPC: 619659115722). I bought it at a Target, but it also seems to be on Amazon at

That’s great news! I bought the newer model. Hoping it works for me too.

Agreed. My next NAS will definitely be more hackable.

Thanks, davesarver :slight_smile: