Creating Partition in Windows XP


#1

I just bought a new 1TB WD10EARS and I was intending to use it as a data storage drive.  I tried to create a partition in Windows XP, but it only sees it as a 31MB drive.  I tried LInux and it works like I would expect.  Anyone have any idea what I need to do in Windows XP to get it to see the entire drive.  I looked at the Acronis utility, but that just seems to do backups and not partition management tasks.


#2

Does the BIOS detect the true capacity of the hard drive? See if there is a setting to change for it to enable large hard drive. 

There was a patch update to help recognize large drives in WinXP. You could look up on the Win Update website. 


#3

i am having the exact same problem in windows XP 64, I just came from bios and enabled “large” for the drive and still it is 31 MB.

Searched windows update with no result aswell, I just bought the drive today and all i get is 31mb :confused:

please help

Regards 

Kenta


#4

Your Gigabyte (?) BIOS is trying to grab about 2000 sectors at the top end of the drive in order to store a backup copy of itself for BIOS recovery purposes.

To do this, it hides the copy in a Host Protected Area (HPA).

See …
http://en.wikipedia.org/wiki/Host_Protected_Area

… and “Xpress Bios Rescue”:
http://www.gigabyte.com.tw/Support/Motherboard/TechGuide_List.aspx?NewTechID=84

Unfortunately, the BIOS code has a bug that causes it to miscalculate the size of the drive. In your case it reduces its capacity by 1TB, leaving you with only 31MB or so.

You can restore the full native capacity of your drive using HDAT2:
http://www.hdat2.com/