Creating a 3rd party application (Emby)

Hi all,

I recently purchased an EX2 Ultra to create an 3rd party application (Emby) for My Cloud devices and am having troubles getting it to install. I followed the developer SDK but every time I upload my package it fails to install without any explanation or log whatsoever.

It is extracted in _install though and if I manually launch over SSH followed by with the right arguments I have no errors. I can then launch and the app works fine.

@Great_Scottt It appears you are the resident expert here, would you have some time to help me troubleshoot the issue ? I can provide you with my apkg.rc and sh scripts, along with a built package for the EX2 Ultra if you’d like.

Thanks in advance.

Sadly, I’m not the right person to be providing help on this issue (I am a huge fan of Emby and can’t wait to see your app) although I can certainly see why someone would direct you to me.

You did post this to the right board.I’m wondering if this is something @TonyPh12345 might be able to provide some advice on. If not, one of the other regulars should (hopefully) be able to help.

Nope, sorry, I have no experience with SDK/development of packages.

Thank you both for your answers. Would you happen to know someone wo’s familiar with the SDK then ?

I’m quite at a loss, all the more because I’m sure there’s nothin wrong with my package. I even tried generating a package from one of your official apps. Copied the whole Transmission app from the NAS and generated a package with mksapkg and got the same result, the package refuses to install.

I’m really not sure who would be a good resource for this one. The only other place I could think to get in touch with is High-Performance SSDs, HDDs, USB Drives, & Memory Cards | Western Digital has a link to - that’s not a support e-mail so I’m not sure who that goes to or how long it takes them to respond to questions if they do.

Thanks, I just shot an email at that address, we’ll see how that goes.

Any news on this?

I need to contact WD’s support to get the packaging issue sorted out. But first I need Microsoft to produce a working procedure to build their dotnet core runtime for armel, or publish an official one. I don’t know why MyCloud devices run an armel OS when their arm chips support armhf, at least that one would have been supported by Microsoft already.