CrashPlan and My Cloud Drive

Sorry for the late reply buchant, I failed to check the “Emal me when someone replies” but to answer your questions:

1.  Yes I was using the latest version of Crashplan (3.5.3 at the time).  There has been a release since, but I have not updated it yet.  I’m going to wait until my 300 GB of data gets uploaded first.  It’s been about 6 weeks and is at 95%… PAINFULLY slow

  1. I have not updated Java yet, still using OpenJDK 1.6.0_27.  I do plan to undertake that at some point.

  2. I have configured it to start automatically after booting under /etc/rc.local by inserting this command: /usr/local/crashplan/bin/CrashPlanEngine start

  3. I did not backup any configuration files on MyCloud, although I probably should have.  It would be good for WD to make their Mycloud OS available for users that attempt this, because it’s really easy to foul up your system.

The only thing I will add to this is that yes the procedures detailed here MyCloud Instructions worked up to the point of step 12, changing out the file.  The precompiled file in that link did not work for me, and compiling it on MyCloud was not an option because of the extensive library updates required to do so.  But the link to this file finally solved that issue for me… after days of meddling.  Anyway, looks like you already solved your issues, but I didn’t want to leave this hanging.

Hi mtvann,

Thanks for getting back!  I have given up on backing up directly from My Cloud to Crashplan because of the ridiculously slow backup speed.  The best speed I ever sustained was around 1.2Mbps but mostly it was around 400Kbps (often less).  I tried changing the destination server serveral times with no improvement.  I tried the newest version of Crashplan and tried different versions of Java, all with no improvement.  

The amount of data I was trying to backup is about the same as you.  When the projected days to complete moved to over 50 days I gave up.  Crashplan customer support was zero help.  They do not support the headless configuration and furthermore don’t support it running on an ARM processor.

Just a few days ago I connected an old Windows laptop to my network, mounted the My Cloud as a drive ( see here) and loaded Crashplan to back it up.  Now I’m getting 4-6Mbps so my data is projected to backup in less than a week in total.  I’m not thrilled with having the extra computer but at least it is a workable solution.  Also, the My Cloud is now a lot more responsive since it is not running Crashplan.  

1 Like

I gave up on CrashPlan on the device and went with the instructions in your link. This is working just fine right now.


If you are interested in detailed instructions you can try my new post.