Cover art doesn't show for new movies

Hey all,

Got a bit of an issue here. Up until a few days ago, the Media Library function for my collection of about 350 Bluray films was working perfectly. I could do the whole “Scan for Info” function to get cover art, metadata, and backdrop images for all the films. Suddenly and completely randomly, I hadn’t changed any settings or anything, the cover art no longer shows up for any movies I scan for info now. The scan works properly, identifying the film and year, then go on to the next window where it shows the cover art and all the metadata information for the film. After confirming that window, I get the same usual spinning arrow in the center of the screen that used to show it was loading the data.

So basically the whole online scan for info from the Hub works perfectly but at the end it’s always missing the cover art. The film’s metadata and information and backdrop images are there and work and show up perfectly, but not the cover art, it stays in that black box with a projector symbol that’s always the icon before you scan for info and get the cover art.

I’ve turned the Media Library on and off several times and it recognizes new movie files that I’ve added to the collection, but still doesn’t show the cover art after I scan. I tried removing/clearing the data and then re-scanning, but that made no difference.

Does anybody have any idea what might be causing this problem and how I might be able to fix it?

Thanks all, much obliged.

It doesn’t seem to be just you.

I just biught one of these things to “upgrade” my WDTV Live and I cannot get the covert art to work either.

However, plain folder cover art works fine, as does the TV. But for DVD/Blu-Ray no cover art, just the background and the metadata.

As my wife is a “visual thinker”, she wanted this feature more than I did. :frowning: And when she’s not happy, I’m not happy.

Easiest solution:  Rollback the firmware to the previous version.

1 Like

OK guys I got mine to work, but I have to do this workaround every time I want to get the cover art for a new movie, which isn’t too often because my collection is pretty much full. Anyway, Media Library is on in the options, do the whole Get Information or scan for cover art that gets the backdrop images and the metadata and all that stuff. After you’ve done it for all the films, even though the cover art doesn’t show, turn the unit off and unplug the power for about a minute. When you plug it back in, the unit boots up automatically without having to press any power button and we get the flashing white WD logo on the front, and it somehow quickly refreshes the media library and displays the missing cover art. Now it is unusual because it won’t work if I turn Media Library off and then back on from the settings, because that is also supposed to rebuild the media library and the front logo will also flash when you turn the media library back on, but the cover art doesn’t show up unless I fully reboot the unit, after which it works perfectly. But again, you probably want to get a lot of your movies together and get the info for all of them so you don’t have to unplug your unit every time you add a movie, if that’s inconvenient for you.

Anyway, why don’t you guys give it a shot and see if it works? Let me know, I’m interested in seeing if the same procedure would work on another unit.

I tried the powering off route, and it did not work.

I am going to try rolling back the firmware revvision; I’ll let you know…

Yay!! The rollback worked!!

(from 2.08.13 to 2.07.17)

Now I (can tediously obtain and) display cover art! :slight_smile:

The wife is a little bit more impressed.