Could anyone please help? My computer wouldn't recognized the 1TB WD Passport

Hi,
I accidentally unplugged my 1TB WD Passport while working on a file that is saved in it. When I plugged it back in, my computer wouldn’t recognized it. Yet, the light was on and there was sound. I had tried to Google for solution, but none of them worked. Could anyone please let me know is there anything I can do? Below is the information of my WD Passport and the solutions I had tried. I had also plugged it into a different USB port and tried to pulugged it in another company, but it didn’t work.
Thank you for your help.
P/N: WDBACX0010BSL – 00
Laptop: Fujitsu T310
OS: Windows 7
Solution #1:
Click on Start --> In search box, type cmd. When it show “Command Prompt” in the search list,
right-click on it and select the option “Open as administrator”.
Open the command prompt and type the below commands
set devmgr_show_nonpresent_devices=1 --> Press Enter
start devmgmt.msc --> Press Enter
“Device Manager” window will be opened.
Now in the device manager, click on “View” --> Select “Show hidden devices”
Now expand the nodes “Disk Drives” and “Universal serial bus controller” by clicking on “+” symbol. If you find any greyed entries --> Right click on it --> Select “Uninstall”.
Restart your PC and connect your external drive.
Solution #2:
1)Unplug ALL USB devices.
2)Open Device Manager.
3)View, Show
Hidden Devices.
4)Uninstall all devices under USB Controllers.
5)Uninstall all
devices under Disk Drives that you know are not present.
6)Uninstall all
devices under Storage Volumes. Say no to any reboot prompts until you are
finished. Also, if a Storage Volume doesn’t uninstall, ignore it and move to
the next one.
7)If you have a yellow ? with unknown devices, uninstall all of
the entries there as well.
reboot pc
Reconnect the USB devices
Solution #3:

  1. Explorer - right click on Computer - Manage
  2. Disk Management in left window
  3. In lower portion of middle window find your external drive (maybe Disk 1). Try disconnecting and reconnecting USB cable to identify if having difficulties.
  4. Right click inside a white rectangular block - Change Drive Letter
  5. Assign a different letter (ex: P)

You can also try the steps provided on the link bellow:

http://wdc.custhelp.com/app/answers/detail/a_id/1164

Hello,

Seems to me that your drive is still working but the partition is corrupted. You may format your drive in order to be able to use it again. However, please note that formatting the drive will delete all data stored on it.

How to partition and format a WD drive on Windows (8, 7, Vista, XP) and Mac OSX