Corruption, harddisk now RAW, partition not detected by testdisk

hi, anyone has any thoughts about my case? here’s a summary:

Windows 7
1 terabyte My Book 3.0 partitioned into 687.37 gig & 244.14 gig
original FAT table was unchanged from purchase, i’m not sure if it’s FAT32 or NTFS

one day the whole hard disk became undetectable.
after testdisk Analyze taking 72 hours, it was detected as
model number: WDBAAK0010HCH-00 1911B
Drive J: - 738 GB / 687 GiB - WD My Book 3.0 1123
CHS 1441517568 1 1, sector size=512

So what happened was, it managed to detect the first partition as “Drive J:” with the correct size. however, the reported geometry is (probably) wrong. It did not detect the second partition.

Disk Management also reads two “drives”, both RAW, in the correct sizes 687.37 gig & 244.14 gig.

I tried to key in a different geometry. I got some further geometry information after consulting Western Digital support centre, as
Western Digital Caviar Black, 64 mb cache, model: WD1001FAES-00W7A0
LBA: 1953525168

So it seems that sectors = 1953525168 x 512 sector size = 1 terabyte, that seems to fit. except that
LBA: 1953525168 does not fit exactly into 255 heads 63 sectors, there is a decimal place. it seems that others on the internet have a similar strange geometry as well, see link:

I used the numbers derived, as recommended on the net, to re-Analyze testdisk.
cylinders 121601 heads 255 sectors 63 size 512
the analysis was very very fast, within a few minutes, but partition detected was nothing.

Since it detects Drive J: as the first partition, I tried to calculate how many heads this partition will take, and enter geometry as:
89730.5228822 so I have to enter 89731 cylinders, heads 255, sectors 63, size 512
Also, nothing got detected.

not sure what happened in my situation, seems that everyone’s managed to testdisk a solution way earlier than me. I didn’t accidentally format my drive either, nor damage it. it happened spontaneously.

testdisk only allows me to “A” add my own partition information, or “L” load some information, but does not detect anything to help me. 

anyone has any further thoughts what might be happening? most suggestions I am receiving are last-ditch methods, am I down to that? 


Try the EaseUS Disk Wizzard A final thing I have read sometimes fixes a Raw drive is to run the command prompt to convert FAT32 to NTFS. Scroll down about halfway to see the prompt  . In Vista and Windows 7 run command prompt an an adninistrator.


1 Like

thanks again! I did not dare to do this next step yet - trying to assess if there is something wrong with my current methods. 

Do you think I should

(A) try to input some partition information on my own, like start from sector 0 0 0 and put in the last sector found, and hope for the best

(B) or try some other geometry information

Do you also know these My Books - do they come formatted in FAT32 or NTFS? this is 1 terabyte WD Caviar Black unit.


I don’t know about the information part. The My Books for Windows come formatted NTFS.


1 Like

I just installed Easeus. 

The two partitions in the harddisk I lost, now known as Drive J: and Drive Q: (and are both RAW, 0 bytes in files, 0 free space) were both not detected by Easeus, but can be seen in “My Computer” in windows 7.

looks like I must somehow make it detectable first?  Otherwise Easeus can’t even start …


The two “drives” J: and Q: can be detected by Windows 7 Disk Management after a while of scanning, but even after they get detected, Easeus Data Recovery as well as Easeus Partition Recovery both do not detect it. 

I am missing one step? need to do something else?


an update: i removed the HDD from the case and connected it directly to the SATA port on my motherboard. the BIOS recognised it easily but again, the first partition is still RAW. the second partition however is recognised easily and is active, NTFS. 

the problem lies now still in the first partition - it is detected as NTFS and testdisk is able to “write” the detected partition data in, as well as “write” the MBR in. after writing these correctly-detected values in, Windows 7 still does not recognise it as a valid NTFS drive - it still reports RAW. 

findandmount also detects these 2 partitions upon deep scanning (not normal scanning). but after findandmount detects it, there doesn’t seem to be an option to try to REGISTER it or something.  it allows an “Image” option - perhaps to image out the problematic partition - is that the correct path to take? 

so now it seems to be a problem of trying to make the problematic first patition get officially recognised as an NTFS partition, by writing valid partition information in again. Easeus Partition Master does not seem to be able to “write” it in successfully as well. 

Is there some other software other than Easeus that I should try ? 

what is the concept of the problems I am facing? the first partition’s information got corrupted, and now does not want to be written back in again? 

thanks !

I have the exact same problem. My drive is coming out as a RAW format in disk manager and I tried test disk to. DId a quick scan with test disk but it found no partitions. I tried the recovery software that comes with test disk but it gets my files but there’s all messed up names and its just useless. What can I do? Help plz.