Corrupting 4TB Green


I have a WD 4TB Green drive in a USB enclosure connected to a Vista computer. It is partitioned GPT style - NTFS. It is shown as healthy in Disk Management with 3725 GB in capacity.

The problem: If I copy files onto it using Copy and Paste with Windows Explorer, everything is fine but if I add files with third party applications, the result is often, though not always, a corrupted file system on the drive.

I’m thinking that maybe Windows Explorer knows how to get around the ‘4TB problem’ but the other applications have difficulty with it. Thanks for any ideas.



Welcome to the WD Community.

Have you tried using the drive on a desktop computer connected internally? If yes, does the same happens?

1 Like

Are these third party applications really old, from XP days? If so, perhaps they do not understand GPT.

I once had a situation where drives became corrupted. I figured out that I had a USB flash drive with problems. Every time I inserted it into a PC, the drive because corrupted. That toy is now in the trash.

1 Like

I haven’t connected the drive directly because it works perfectly when I Copy and Paste with Windows Explorer; it corrupts only when I use the other apps (Mezzmo and a video file converter). Both the third party apps process the files and then save them automatically to the disk in question. If the USB cable or the enclosure where the source of the problem, I assume that all operations, including Copy and Paste, would be trouble.

Both apps process video/audio files and save the output directly to the disk. One of them (Mezzmo) is a 2014 version.

I agree Steve55419, since the copy and paste works fine, it seems that the enclosure and disk are working. Since it only happens with your specific program/app then it seems like it is the issue. Have you tried contacting Mezzmo to see if they heard of the issue or if it has any limitations? Can you have it process video/audio to a different drive and see if it still corrupts the data?

1 Like

LB: It’s a real puzzle. The two third party apps are ‘Mezzmo’ and ‘Aiseesoft Total Video Converter’ and it would be quite a coincidence if two different apps had the same defect so it’s safe to say it isn’t the apps. And, for reasons already stated, it’s also safe to say it isn’t the USB cord or enclosure. And I don’t think it’s the drive itself since I did a full format (some 45 hours or so) before using it.

My Vista OS is SP 2 and, for some reason, I can’t do Windows Update. I wonder if the way Vista SP2 dealt with >2TB drives was flaky in any way and whether SP3 would fix it?

If I figure this out, I’ll post the solution. Thanks.

I agree with the moderator. I think it is the two apps.

As for your Vista having a broken Windows Update, peruse the following two Microsoft links:

@Steve55419, is it possible that your enclosure is configured with a 4KB sector size? ISTR that Windows 7 Backup was unable to handle 4Kn drives. Perhaps some applications have similar problems.

You can determine the sector size by executing the following line from a CMD prompt:

fsutil fsinfo ntfsinfo X:

… where X: is the drive letter.