Corrupted MBR, 1TB myBook Essential


#1

I cannot connect my external hard disk, WDBAAF0010HBK; My Book Essential 1TB.

The drive shows up as unallocated, and trying to rebuild the partition. Up to now, I found that the MBR has been totally corrupted and partition rescue utilities have not worked yet.

Could someone please send me the MBR data of a healthy 1TB MyBook Essential hard disk. My last option is manually patching the MBR. As you know, you can get this data by running :  “#> dd if=/dev/sdb of=mbr bs=512 count=1” in a Linux machine, considering sdb is the disk that you want to get its mbr data. There are some other free tools work on MS Win.

you can send the file to my e-mail: ig004@hotmail.com

Thank you in advance.


#2

Hello,

Please check the link below:

http://www.suggestafix.com/index.php?showtopic=31945


#3

Elsewhere you’ve asked me to help you in this thread, but I don’t know if I can.

At any rate, unless you wish your drive to be bootable, you only need to reconstruct the partition table. There is no need to refresh the MBR code.

If the drive still has a valid, uncorrupted boot sector, then you should easily be able to rebuild the partition table using the information in the boot sector.

Typical locations for this sector are LBA 63 or LBA 2048. NTFS also has a backup boot sector at the very end of the volume. FAT32 has a backup at logical sector 6.

If you can find such a boot sector, then upload its contents and I’ll rebuild the partition table for you.

BTW, are you accessing the drive via a SATA port, or is it still behind a bridge board in a USB enclosure? Be aware that Essentials drives are hardware encrypted, so if you connect via SATA, all you will see will be jibberish.


#4

Hi,

Thank you very much for you rreply. Since I saw your replies to similar problems, I thought that you may have some clues about the solution.

I connected the drive to the computer via SATA cable. Before doing that, I contacted WD technical service and I asked whether there is difference between them or not, and they say no. Encryption is done for all HDs or only for the HDs that encryption is enabled by the user. I don’t think that I manually enabled the data encryption.

Here is the mbr:

https://skydrive.live.com/?sc=photos&cid=c2924a84c67173b2#!/?cid=c2924a84c67173b2&permissionsChanged=1&id=C2924A84C67173B2%21143!cid=C2924A84C67173B2&id=C2924A84C67173B2%21144

Do youthink that, this is a corrupted MBR or encrypted jibberish ?

Thanks again.


#5

The data are hardware encrypted whether or not you have set a password.

Here is a direct link to your image (no ads, banners, popups,etc):
https://sn2files.storage.live.com/y1puG0n6U96EVVPHBdUgaeXSPFktc0mC1p6PybovRpm1fJ_X2RH4sWPDoFldXMtm29magqq_GWXcaA/mbrCapture.JPG?psid=1

Starting at offset 0x00000180 you can see three identical lines of 16 bytes (78 5F 69 … 03). These represent three lines of encrypted zeros. The encryption algorithm is AES 128-bit (128 bits = 16 bytes).

You can also see two more such lines at offsets 1D0 and 1E0. This is where the information for the 2nd and 3rd partitions would be stored. Therefore the pattern is consistent with an MBR that has a partition table consisting of a single partition.

You need to reinstall the drive in its original enclosure in order to see your data. If the USB-SATA bridge board is faulty, then you will need to repair it, or replace it with an identical board from an identical product of the same capacity.

If you can’t obtain an identical replacement, then you will need to transplant the 8-pin serial flash memory chip from your original bridge board to your donor.


#6

So, the proposed solution above, fdisk /mbr cannot be a aolution.

I’ll try to fix the usb brisge card.

Only MBR is encrypted or are MBR and partiton tables encrypted ? I don’t think whole disk is encrypted since data recovery tools could find some text, image and pdf files in the disk.


#7

The entire user area of the drive is encrypted. I believe the “files” that your data recovery tools are finding may be bogus. As the old adage goes, when you have an infinite number of monkeys typing on an infinite number of typewriters for an infinite amount of time, eventually one of them will produce the complete works of William Shakespeare. I suggest you save one of the text files, if possible, and open it in both a text editor and a hex editor such as HxD (freeware).

That said, if your external drive is one of the earlier ones, then it will have an unencrypted 700MB SmartWare area at the end of the drive, past the end of the user area. When the drive is inside the enclosure, the bridge chip presents this SmartWare code as a Virtual CD. However, when the drive is outside the enclosure, this area is exposed to the user. Therefore I wouldn’t be surprised if the data that your software finds are SmartWare files.


#8

Thank you so much.

Your guidance helped a lot. I repaired the usb bridge card and now everything is OK.

To drop a note here, WD community;

  1. As opposit to the technical service explanations, it does really differ to connect the disk to computer via usb or via sata. Since the whole disk is encrypted (by usb bridge card) you cannot see the MBR and partition tables correctly when you connect via sata, so all disk seems as unallocated.

  2. Through sata, data recovery tools can find files in disk. If the file is recovered coorectly it is highly likely from WD Smartware part. Otherwise the size of files are sometimes defined as so huge (maybe larger than disk volume) or contents do not have meaning.

  3. I replaced the usb brdige card with one from another MyBook Essential but a newer version, with USB3.0 support. However it didn’t  worked. Previous version number is 1110, the new one is 1130. If you want to replace the card, find the exactly  same version.

  4. discovered that broken usb card needs some soldering only, repaired and OK…