Corrupt Drive?

I ripped my entire DVD collection to MKV format on my hard drive (WD Ext HDD 1021 (USB).  There are about 500 videos on my hard drive and they are organized in folders by genera then by rating.  I purchased a Western Digital Media Player so that these files could play correctly.  I disconnected everything a few weeks ago but when I connected it recently only some of the files and folders are showing instead of all of them.  I thought it was the player so I went out and got a new one but the hard drive is still having the same issues.

What’s really weird is that when I hook it up to my computer I can see the files but they all have a weird file extension of thumb_73x104 and all of the files are super small.  In addition,  I knew I was close to the final capacity of my hard drives memory and when I look at it on the C drive it says 106 GB free of 1.36TB but all of the files that have the thumb_73x104 extension are super small, like under 30kb’s.  The drive is only a little over a year old so as you can imagine my kids are very upset that all of their movies are no longer playing.  I ran the Data Lifeguard Diagnostics for Windows program to test the drive (this software is provided for free from WD) but it said the drive passed. I also ran the extended test and still no errors.  When I first connected the drive to my computer it asked me if I wanted to 1) scan & fix errors or 2) ignore, I opted for 1 then asked it to automatically fix files with system errors and to scan for and attempt recovery of bad sectors.  After running this nothing changed, the files still have the thumb_73x104 extension on them and do not work.  If I remove the thumb_73x104 and just leave the file_name.mkv the file still doesn’t work.  I also ran recovery software (Recuva) on the drive and it found some videos but they were from my camera not the burned DVD files.

I have googles this and haven’t been able to find anything anywhere. I also put a ticket into Western Digital Support but I have not heard back from them and it’s been 3 days.

If anyone has any ideas on how to fix this I would greatly appreciate it. 

The “thumb” files are just thumbnail cache files.  They aren’t your original movie files.

Sounds like the filesystem got corrupted, but it’s strange that a “scan & fix” would not find the files, or at least reset the free space…

Yeah, it’s also weird that my drive is so full if the files are actually gone.  Do you have any suggestions on how to retrieve the files?

Try using this tool:

to see if you can narrow down where the space is being consumed.

Thank you. It looks like my files got moved to a very different location.  The program you provided helped me see where they were and I was able to move them back.  You are a life saver, my kids are very, very apprecitative.

Glad I could help. :wink: