Corrupt Dashboard?

Brand new WD MyBookLive 2Tb, working exactly as it should up until yesterday - when trying to access the unsecured dashboard through my MacBook I am given this page:

Screen Shot 2012-06-09 at 12.53.30 1.JPG

File access still works, WD Quickview has no troubleshooting errors. Tried using different browsers & clearing their caches, restarting the MyBook and MacBook. Tried using MyBooklive.local, MyBooklive and also the direct IP address to try to gain access.

I can access the SSH settings page with no problems at all which leads me to believe that the content for the front page must be corrupt/missing when the shell of the dashboard and other content is working.

The HTML coding of the page shows no content where the right hand pane should be -

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="Cache-Control" content="no-store, no-cache, must-revalidate" />
<link href="/UI/favicon.ico" type="image/x-icon" rel="icon" />
<link href="/UI/favicon.ico" type="image/x-icon" rel="shortcut icon" />
	<link rel="stylesheet" type="text/css" href="/UI/themed/default/css/aggregate.css?ver=02.11.09-053" />
	<link rel="stylesheet" type="text/css" href="/UI/themed/default/css/jquery_ui/themes/default/aggregate.css?ver=02.11.09-053" />
<script type="text/javascript" charset="utf-8"> var SITE_BASE_URL = '/UI/'; </script>
	<script type="text/javascript" src="/UI/js/aggregate.js?ver=02.11.09-053"></script>
	<script type="text/javascript" src="/UI/js/jquery/jquery.bind.js?ver=02.11.09-053"></script>
	<script type="text/javascript" src="/UI/js/jquery/select2UISlider.js?ver=02.11.09-053"></script>
	<script type="text/javascript" src="/UI/js/cookies.js?ver=02.11.09-053"></script>
	<script type="text/javascript" src="/UI/js/support.js?ver=02.11.09-053"></script>

<title>
MY BOOK&reg; LIVE&trade;</title>
<!--[if lt IE 8]>
	<link rel="stylesheet" type="text/css" href="/UI/themed/default/css/ie7.css?ver=02.11.09-053" />
<![endif]-->

<!--[if lt IE 7]>
	<link rel="stylesheet" type="text/css" href="/UI/themed/default/css/ie6.css?ver=02.11.09-053" />
<![endif]-->
</head>

<body>

<noscript><div id="noscript"><h1>Please enable JavaScript.</h1></div></noscript>

<script type="text/javascript">
if (are_cookies_enabled() == false) {
    alert('Please enable cookies on your browser.');
}
</script>

<script type="text/javascript">
	var restore_in_progress = false;
	var deviceName = 'MyBookLive';
    var nasModelNumber = 'AP1NC';

    var supportedFeatures = new Array();
    </script>

<div id="mybooklivetxt" style="display:none;">MY BOOK&reg; LIVE&trade;</div>


<div id="hide_footer_trigger">

<div id="header">
    <div id="header_content" style="text-align:right;">
		<a href="http://www.wdc.com" target="_blank"><img src="/UI/themed/default/img/common/logo.png" id="logo" alt="" /></a>
        <table cellpadding="0" cellspacing="0" align="right">
        <tr>
		<td>
        <div id="usb_positioning_div"></div>
        </td>
        <td>
        <div id="alerts_positioning_div"></div>
        </td>
        <td>
        <div id="header_links">
                        <a href="/UI/logout" class="is_secure_depends" style="display:none;">Logout</a> <div class="not_secure_depends secure_device_link_container">
            <a href="#" class="secure_device_link">Secure Your Device</a>
            </div>
            <!-- this is only for testing... DELETE BEFORE PRODUCTION -->
            <br />
                        <br /><br /><!--<a href="/users/output" class="ajax">Show Session Data</a>-->
            <!-- -->
        </div>
        </td>
        </tr>
        </table>
    </div>
</div>
<div id="container">
	<div id="left">
		        <div id="learn_center">
    <div id="learn_center_toggle">
    Let us help you </div>
    <div id="learn_center_content">
    	<ul id="learn_center_ul">
											<li id="learn_register_li">
					<div id="learn_register" class="register" >
					<div class="learn_center_item_title">Register Your Device</div>
					Be sure to register your device to receive important product news and firmware updates. </div>
				</li>

			            <li id="learn_remote_li">
            <div id="learn_remote" class="learn_center_item_title">
			<div class="learn_center_item_title">Access Your Media</div>
                Set up your device for remote access by WD Photos&trade; and WD 2go&trade;. </div>
            </li>
            <li id="learn_users_li">
            <div id="learn_users">
                <div class="learn_center_item_title">Create Users</div>
                Add new users and assign their access levels. </div>
            </li>

            <li id="learn_shares_li">
            <div id="learn_shares">
                <div class="learn_center_item_title">Create Shares</div>
                Add new shares and grant users full or view-only access to the content you want to share. </div>
            </li>
            <li id="learn_safepoint_li">
            <div id="learn_safepoint">
                <div class="learn_center_item_title">Create Safepoints</div>
                Create Safepoints and protect yourself against device failure. </div>
            </li>
						       </ul>
    	<div id="learn_center_navigation"></div>
    </div>
</div>

        <div id="replication_progress_element" style="display:none;cursor:pointer"> 		
            <br>
            <span id="replication_progressbar_footer_title">Creating safepoint</span>
            <span id="replication_progressbar_footer_percent"></span>
            <div id="replication_progressbar_footer"></div>
		</div>

    </div> <div id="right"> <div id="content_scroll"> <div id="content"> </div> </div> </div>
</div>
</div>
<div id="footer">
    <div id="footer_content">
        <a href="#" id="device_status_message" class="helpLink" title="Good">
        <div id="device_graphic" class="good"></div>
        </a>
        <div id="device_display_name" class="device_display_name">MyBookLive</div>
        <div id="device_display_status">Status: <span id="footer_status_class" class="footer_status_good">Good</span></div>
        <div id="footer_chart_container">
			
<script type="text/javascript">
	var usage = [{"name":"music","gb":"11","percentage":"0.55"},{"name":"photos","gb":"27","percentage":"1.36"},{"name":"video","gb":"245","percentage":"12.32"},{"name":"other","gb":98,"percentage":"4.93"}];
	var deviceCapacity = 1988;
</script>

<div id="usage_chart_wrap">
    <div id="usage_chart">
        <div class="usage_indicator music"></div><div class="usage_indicator photos"></div><div class="usage_indicator video"></div><div class="usage_indicator other"></div> <div id="all_usage_indicator" class="usage_indicator all status_good"></div>
    </div>
        
    <div id="indicator_label_wrap">
        <div class="usage_indicator_label music">.Music</div><div class="usage_indicator_label photos">.Photos</div><div class="usage_indicator_label video">.Video</div><div class="usage_indicator_label other">.Other</div> </div>
</div>
<div id="all_usage_label" class="usage_indicator_label">
Usage: <span id="totalusage">381 GB</span> / <span id="totalsize">2 TB </span></div>
        </div>
    </div>
</div>

<div style="display:none">
    <div id="footerstatusgoodtxt">Good</div>
    <div id="footerstatuswarningtxt">Warning</div>
    <div id="footerstatusinitializingtxt">Initializing</div>
    <div id="footerstatusinitializingdevicetxt">Initializing device</div>
    <div id="footerstatusbadtxt">Bad</div>
    <div id="footerstatustempbadtxt">System over-temperature</div>
    <div id="footerstatussmartbadtxt">Drive SMART failure</div>
    <div id="footerstatusvolumebadtxt">Data Volume failed to mount</div>
    <div id="footerstatusfreespacebadtxt">Disk usage is above 95%</div>
    <div id="footerstatusraidbadtxt">Storage failure</div>
    <div id="footerstatusraiddegradedtxt">Storage degraded</div>
</div>

<div id="alertNotificationContainer">
    <div id="alertNotificationHead">
        <a href="#" class="alert_notify"><img src="/UI/themed/default/img/common/alert.png" alt="" /></a>
			
    </div>
    <div class="alertsDisplayToggle">
        <div id="alerts">
			
<div class="alertContainer" style="display:none">
<a href="#" class="alertClose" rel="_template"><img src="/UI/themed/default/img/common/alert_close.png" alt="" /></a>
    <div class="alertTitle"></div>
    <div class="alertMessage">
            </div>
        <ul class="alertLinkList" style="display:none">
        <!-- <li><a href="http://www.wdc.com/wdproducts/updates/?family=wdfmb_live" target="_blank">Release Notes</a></li> -->
        <li><a href="#" class="auto_update_trigger">Begin Update</a></li>
    </ul> 
    	<div class="alertTime"></div>
    <div class="alertOptionsContainer">
    <table cellpadding="0" cellspacing="0">
        <tr>
            <td style="vertical-align: top;"> <input type="hidden" name="data[alert_disable]" id="_template_" value="0" /><input type="checkbox" name="data[alert_disable]" id="_template" label="" value="1" /> </td>
            <td> <div class="alertCheckboxLabel">Don't show this alert again.</div> </td>
        </tr>
    </table>
    </div>
</div>
			        </div>
          <div id="alertNotificationFoot" style ="display:block"></div> 
    </div>
</div>
<!-- Build empty form for ajax posts with no form of their own -->
<form id="empty_form" method="post" action="/UI/generics/add"><fieldset style="display:none;"><input type="hidden" name="_method" value="POST" /></fieldset><input type="hidden" name="data[Generic][empty_field]" value="" id="GenericEmptyField" /></form>
<form id="safepoint_progress_form" method="post" action="/UI/backups/none"><fieldset style="display:none;"><input type="hidden" name="_method" value="POST" /></fieldset><input type="hidden" name="data[Backup][safepoint_handle]" value="test" id="safepoint_progress_form_input" /></form>


</body>
</html>

Can anyone help with how to correct this error so I can get access to the dashboard?

You can try resetting or updating the firmware

Hi Wizer

Updated the firmware tonight (it was already up to date but I overwrote the firmware there already) but no change. Exactly the same scenario as above.

Cheers

Gregor

Gregor:

Just curious:  how did you update the firmware when most of the UI (including the menu to do the firmware update) is missing?

I downloaded and copied the deb file to the MBL and used an SSH command to invoke the firmware upgrade script using the downloaded and copied file as the source.

Cheers

Gregor

Have you tried a different PC or a different browser?

Did anyone find a solution to this ? I have exactly the same but no SSH enabled. Seems silly to have to send back the drive, as advised by WD, just because a HTML page or two is not working.

Hi VanderW, i wish the problem solved, and would you pls tell how to solve it, thanks.