Correct password is not allowed

I put a password for my new external harddisc and i try to check it immediately,but even i write the correct password(i am sure),it says it is incorrect.I tried the offered solutions which includes macbook language change to en-usa ör en-uk and i also tried to uninstall driver on windows.Both did not work.i paid too much for 4 tb driver but all i get is losing my documents,it is a software problem i think.what shall i do ??help pls

Hi @Melis,

Please be informed that Western Digital neither covers Data Recovery under its warranty policy nor has any in-house data recovery service. But it does provide approval for the data recovery from any alternate 3rd party options.

For a detailed list of which WD external drives support encryption, and if data recovery is possible, please check the below link.

Title: WD External Drive Encryption Compatibility Matrix
Link: WD External Drive Hardware Encryption Compatibility Matrix

If further assistance is needed, please open a case with our support team at the following:
https://kb.sandisk.com/app/ask