Copying to MBLD, Error Code -50 and Permissions Errors

Hi, I see there is already another thread about this issue.  I’m starting a new thread in the hope of getting some answers, seeing as nobody seems to have solved this one.

Most data is copying to my MBLD just fine with drag and drop. It’s slow, but setting up NAS right in the first place is always slow.

I am occasionally getting two copy problems.

  1.  Error Code -50.  This is only happening with one folder.  I’ve tried numerous things below, and nothing seems to work:

a)  sure permissions for every file in the folder are set to everyone, 
b)  zipping the folder first, copying it over, then trying to unzip on the NAS (for which I get error 22 - invalid argument)
c)  dragging and dropping the files inside the folder one at a time (get error -50 for each one)
d)  dragging and dropping from different locations, including external drive, dropbox folder, or the computer desktop
e)  I even tried a terminal command workaround on apple’s help page

  1.  Permissions Errors.  Some files tell me I do not have the appropriate permission to copy the files.  I’m not sure how to fix this one.  

Any help with either would be much appreciated, thanks.

Hi, check if the link below helps.