Copying files from usb1 to usb2 fails sometimes


#1

Hello,

first: please excuse my bad english, its not my mean language, i’m from germany.

i have a problem with copy files from usb1 to usb2, but not always.

Most i do like this:

copy media from my pc to an Usb-stick, plug the stick into my wd tv live, going  into the (wd)-Menu and start copy the file/files to usb2 (always connect ext. usb-drive on usb2). Most time it works (have > 5000 files on my drive at usb2 in different subfolders).

now i have the problem, that some files won’t be copied (2 different messages: 1 says targetmedia is write-protected, 2 says 'there is a problem with the target).after message theres the new folder and subfolder on the target, but no media/file in there. copy the files separatly starts (shows the progressbar), but when it’s ready, again the errormessage (1 or 2, sometimes 1 sometimes 2)

If i ignore that and copy another file, it works fine, no error, no message - just done right.

I checked the files (no write protection on folder/files on the source), the files are 3x 1024 MB and 1x 369 MB.

so i wonder, what is wrong or how can i fix the problem?

anyone here who can help me?

thanks for reading this and maybe for helpin me


#2

It sounds like something might be wrong with one of the drives. I would connect them both to a PC and run the manufactuers diagnostic on the drive (If it’s a WD you would use Data Lifeguard Diagnostics). If it passes the test, defragment each drive and use Windows error checking on it. If the issue continues to occur, backup the data on each drive to a different location (using the computer) than write-zero’s to the drive, and reformat it to see if this helps resolve your issue. This will wipe out all the data on the drive, including all of the partitioning which may be part of what’s causing the problem.

Verwenden von “Bing” ins Deutsche übersetzt: es klingt etwas falsch mit einem der Laufwerke werden könnte. Ich möchte schließen Sie beide an einen PC und führen Sie die Diagnose Manufactuers auf dem Laufwerk, (wenn es sich um eine WD, verwenden Sie Data Lifeguard Diagnostics handelt). Wenn es der Test ist erfolgreich, Defragmentieren Sie jedes Laufwerk zu, und verwenden Sie Windows Fehlerüberprüfung auf es. Wenn das Problem weiterhin auftreten, die Daten auf jedem Laufwerk an einen anderen Speicherort (mit den Computer) als Write-0 (Null) auf das Laufwerk, die, Backup und neu formatieren, um zu sehen, wenn dies hilft, Ihr Problem zu beheben. Dies wird Wischen Sie die Daten auf dem Laufwerk, einschließlich aller die Partitionierung, die Teil der was das Problem verursacht werden kann.


#3

Thanks for the fast answer. I’ll try the things you wrote next weekend and post my experience. It’s not a WD-Drive (a WD-Drive (one of the ‘My Passport’) will be my next ext. Drive when my money allows me to buy one), but as i said, a lot of Files still work fine, only this 4 files make troubles. I tried to copy other files before,(hoping the 4 Files will be on a other place on the drive), but that also fails. Next weekend i will try to copy the files via PC to that drive, i like to see what happens then.

Again, thanks for helpin me

Btw.: it’s really nice to try to translate into german via Bing, but Bing (and many other ‘auto-translate-tools’) can’t do that, the output is … hmm … some kind of alien-language?? ;)  Reading english is much easier for me than writing, so feel free to answer just in english.


#4

hehe - I know what you mean about Bing - it does the same kind of thing going the other way, but is better than nothing. I wasn’t sure how good your english was, so I figured I’d place it in both just in case.

How are the drives formatted? Also how big are those files that won’t copy?


#5

The drive ist formatted in NTFS, the files are 3 x 1024 MB and 1x 863 MB. I have connected the drive to my pc today, copying the ‘problem-files’ there was no problem. I couldnt accept ‘ok, works, forget it’, so i did a little ‘try-on-error-work’:

I guess, something in the folder .WD_Tv was wrong.

My Test: i deleted the copied files, deleted the folder .WD_TV from that drive (all done via PC), than i connected the drive again on my WD Player and tried to copy there again - and *tadadaaa* - it works. My problem seems to be gone :wink:

Now i’m happy again with my WD Player :smileyvery-happy: