Converting My Book Essential FAT32 to NTFS


#1

Hi, new to this.  I have a 1tb My Book Essential that used FAT32 file system and then I tried to convert it to NTFS and not sure if it’s converting or if I messed it up.  The light is running/blinking and I can hear it working but not sure if it’s actually doing anything…  It’s ben doing this for a few hours now and I’m starting to get worried. It used to show up in 'my computer" as My Book (E:) but now it’s only showing up as "Local Disk (E:) and when I double click it I get a “Location is not available.  E:\ is not accessible.  The volume is too fragmented to complete this operation.”  Before I tried to convert it, it had about 500gigs of data on it already and I didn’t defrag it before converting.


#2

Are you still having trouble?  What did you do to try to convert from FAT 32 to NTFS?  As I understand it, you can convert from FAT32 to NTFS without losing data but I have never tried it.  Here is a link to a site that tells how to do it but I cannot vouch for it as I have never tried it.  http://hubpages.com/hub/how-to-convert-from-FAT32-to-NTFS    Have you tried to determine the status of the drive by going into Windows Disk Management tool via Device Manager?  Have you powered everything down and rebooted the entire system?    


#3

Yes, converted using the 'RUN>cmd>_ convert e: /fs:ntfs>my book" method. Then it prompted me: _

"Convert cannot gain exclusive access to the drive letter drive, so it cannot convert it now. Would you like to schedule it to be converted the next time the system restarts? <Y/N>"

I selected Yes and the rebooted my computer. It’s been running for over 16hrs now…

Device Manager reports that the device is working. But when I try to look at it I get a message saying that its to fragmented.


#4

Also I just got off the phone with WD’s tech support and they can’t help with conversions and insisted that I “reformated” it.


#5

Sorry but this one is over my head.  It should have done the conversion pretty quickly but it’s obviously not going to happen.  Do you have data on that drive that isn’t  on any other drives and can’t be lost?  If you can afford to lose the data, you may have to reformat the drive to get it functioning.  You said you looked at it in Device Manager but have you looked at it in Disk Management and if so, does it give you any helpful information there?   If you have data you can’t lose, maybe another forum reader with more knowledge will have some ideas.  Having it just running constantly, trying to do something, probably isn’t very good for it.  If you have not already done so, you may want to completely disconnect the drive and then reconnect it to see what happens.   Wish I had more helpful ideas.   


#6

Convert fat32 to ntfs is available. You will find the solution I linked below. Hah, in addition, I think know something useful information related (like convert ntfs to fat32) is necessary, too. So, share with you. We can solve such problems together.:smiley: