Constantly blinking green light

Hey Everyone - So I’ve had my mybook duo for a week or so now and after doing a fair amount of file copies to my device (that appear to complete), my unit always has a blinking green light on it.  I know it’s supposed to have it on when data is being written/read, but it never seems to complete.  I’ve powered it off, reset it, unplugged the network cable, and no matter what I seem to do to it, it still continues to read/write.

The only thing I’ve managed to do to get it to stop is to restore to factory settings (which obviously lost all of my data).  This doesn’t seem to afffect my drive’s performance, but I’m mostly only worried about shortened drive life due to constant being on.

Thoughts?  Or is it time to contact WD support?

If you’re adding a lot of files into shares where Media is turned on, it’s going to take a while for the drive to index them for the Media Server(s).

I am experiencing exactly the same issue.  I only have two shares on the drive both of which have media turned off.  Ever since changing to RAID 1 and copying about 1TB to the drive (which took 1.5 days over gigabit - ridiculous), it is always blinking and you can hear the heads clicking constantly.

I then tried to shut down and restart and then tried turning off any device that would access it.  Keeps working hard.  I updated the firmware and thought letting the hard drive finish its indexing would change that but a day later, still working hard.

I also tried to submit a ticket to WD but their support links all give an error.  Anyone have any other ideas?  :)  Thanks!

So after three days of being patient with the constant blinking, it has calmed down and now will rest an hour or so after all devices have stopped accessing it (with setting of 20 min power saver).  I guess there was a lot more indexing and cataloging needing to be done than I thought.

Has anyone successfully resolved this problem.?  WD hasn’t responded to my requests, and none of the suggestions I’ve come across in the Knowledge Base seem to work.  I would note that when the ethernet cable is disconnected the flashing green stops, which causes me to believe it is some kind of network activity rather than indexing of photos.  The blinking occurs even when my computers are off.  Oddly, for the first three weeks that I had the drive (3tb My Book Live) it went into sleep mode with a blue light on a regular basis.  Very frustrating!

[Update]  Made the mistake of resetting the drive by holding rear the button in for four seconds, and now the drive is not visible at all.  Called Western Digital and spent about 40 minutes with support staff trying to run diagnostics and various other methods of getting the drive recognized on the network, and no luck.  So, I’ve essentially got a $200 dollar brick sitting on my desk with close to 670 gigs of data in limbo.  Again, if anyone has overcome this problem, I’d be glad to know how.

I have done same mistake of resetting and my drive doesn’t work either. But have found a thread probably worth looking at

My drive had a constant blinking green light after I acccidentally knocked the power off. Apart from the blinking green light and that the hard disks were constantly running it appeared to be working correctly. I tried diagnostics test short and full but to no avail. I finally just had to do a factory reset and that sorted it.

As TonyPH12345 mentioned, there are processes that run in the background when you add media. The Media Server has to index your data so it can serve up files for DLNA players. Your photos are transcoded (no we do not touch the original photo) into smaller sizes for our Mobile App WD Photos. This process runs at a very low priority - thus it could take days before it finishes.

Is there a setting to turn off Media indexing? I don’t have any DNLA players, I just really use the MBLD for backups (Networked and RAID system, perfect for my needs)

My Book Live Duo 6Tb

Set to raid 1

Recently set up - most data loaded in one go

I too have the constant green light flashing light problem and constant disk activity. The activity continues even when all PCs on my home network are off and remote access disabled.

Initially all was well and it shut down to the blue light after a short time, however, as with nairb, I too accidently knocked off the power. There is only about 50gb on the drive.

The drive has been at it for three days solid now; when I initailly copied over the files (all in one go) it settled down very quickly, which leads me to believe there is an issue now as one would assume the indexing task would be of the same complexity and size as that initially encountered.

I would rather not do a factory reset as I have things set up just right, and do hope to discover a reason and fix in any event as I would hate to be in this situation a few years down the line with many hundreds of Gbs to deal with.

nairb - if you want to turn off the media steaming then go to drive’s dashboard using a browser, select settings, then under the media tab there is a tick box to turn off the media streaming.


Thanks Derm, I discovered that feature this weekend and turned it off.

BTW I saw in the “Remote Access” tab under “Advanced” there is a button to rebuild the photos database. Perhaps your media server/photo database got corrupted when you hit the power off, it might be worth a try.

I think I was a bit hastly myself in doing a factory reset, it took me about a week to get everything back in order again but it was a good learning experience! You might want to just the mybook continue running for another few days and see if it settle down, perhaps the database rebuild might help?

Hi guys, this my first post, but i just had the same experience. I bought my MyBookLive duo 6tb about a month ago. So far i’ve been moving small files, although in total it’s about 100gigs or so. Yesterday i decided to move my video files (MKVs, AVIs), as this the reason i bought this as i ran aout of space. So i decided to move my files in one go (1.81TB worth of files). Windows said it’ll take 23 hours, which Is not a problem for me as i know moving such amount of files will take time. 24 hours later i want to check the transfer, and then i found that my computer can not detect my drive, and the drive is blinking green. The network is visible in the windows network but that’s about it. I can’t access it. The wd software dashboard can not access it. Tried to double click it and the browser said it can not establish connectiom to the server at the ip address. Nothing works. I was thinking to shut it down but i’m worried i would lose all my data. I dare not resetting it thinking it’ll wipe out the data. i’ve had twice crashed hard drive experience, bot with wd drive so i’m traumatic. Please…please…anyone…i beg you…shed some enlightment of what i should do. Cables are bramd new gigabit and my other NAS (buffalo casing with 2 wdc green 2TB) connected just fine. i live in south east asia (Indonesia) so customer support is not reliable. I tried shutting down my computer and pull the cable and then yellow light blinking instead of green. What frustates me is that the wd software can not detect it so diagnosis is impossible. The WD quick view says my usage is 0% and temperature is unknown. I’m worries this would third time the charm WD drive fail me… Please help…

I am a recent owner of a mybook live duo too recently. I have the same problem. Once every user of my mbl is shut off, the green led in the front of the device will blink every 20 seconds, and never goes to standby (blue). Last week I did a reset to factory defaults, lost all my data, but hey… BLUE led again after 10 minutes inactivity!! Now, 1 week later again, after putting some data back on my device… Same problem again… It never falls in standby (blue), just only green, with a blink in every 20 seconds. It worries me that WD doesn’t come up with a proper solution. I thougt I was the owner of a high quality piece of equipment from a recommended brand… Now i end up plugging out the device every time i won’t use it for some time because there seems to be some kind of bug that WD refuses to aknowledge and help solve…

There are two things you could try:

  1. if you don’t use the DNLA player or iTunes, you can turn off the media player (its somewhere in the Settings section I think?) This seemed to work for me as the media player then wasn’t constantly updating its media library.

  2. Another thing might be your router, my router was setup by default to do DHCP updates (for IP address?) once an hour or half hour, which was constantly waking up my MBL, I switched that to do it once a day and my MBL goes into sleep (blue light) much more regularly now.