Constant CPU overload for months

I’m using my EX4 for more than 6 months, if you could really call it using. After I build RAID, attached 2x USB’s and copied my files it’s CPU jumped to %100. I thought it must be caching or something so I left it alone for days, nothing changed.

Than I disabled every function on it. Media server, DLNA, iTunes etc… No changes.

Still there is nothing enabled on it (incl IP6)

I tried every firmware… No changes.

I can’t even use interface. I have to reset the EX4 (which takes around 5mins) than I get a short window for around 2-3 minutes I can login to interface. So I have to struggle for an hour just to change a couple of settings.

I can’t access SSH since I can’t change it’s password. When I enter new password stays there for around 5 mins than gets back to Network settings but I can’t still access it.

I’m using it with Cat5 connection. I never used any apps, cloud access or backup options.

I used it like this for months because even it was really slow I was able to access files through network. 

My files are mostly big raw video files and huge art assets. I was thinking device is messed up because of thumbnail generation or something.

I upgraded to latest firmware, which basicly made everything worse. Now I can’t even use files over network. For two days I’m trying to get some files one by one and it’s killing me. And since it’s RAID I can’t just take away my drives.

I got to take a peek at process, to see whats hogging it, couple of times and after firmware upgrade it’s always httpd. What I read so far it’s the Apache web server.

Proccess log is %100 for around 3 minutes and %80 for half a minute than %100 again. It’s a constant loop.

Is there anyone who actually, using this thing? Any idea how can I make it work?


I managed to login SSH. I was trying to login with root, it seems user name is “sshd” :neutral_face:

Here’s how top looks like. 

What about running a system only factory restore? Have you tried that?

You have high “sys” and “io” CPU load.  Try killing WDNOTIFIER and see what happens.

Alterntaively remove all USB devices and reboot.

WDNOTIFIER rarely shopsup. Sometimes Samba and Deamon shows up too. But they come and goo. But httpd is always there.

And there is no USB attached

Before coying lots of files, login to the UX and DISABLE “Cloud Service” which will stop the file transcoding process.

NOTE: Doing this will disable cloud access (remote access) but peformance should increase.  After the files are copied, ENABLE “Cloud Service”. Just know that when you enable the Cloud Service, the transcoding of the file will occur at some point.