Connection reset

For the past few months I have had a problem copying files to the NAS with iTunes.

I thought it was iTunes, then my internet connection… I have now narrowed it down to the MyCloud device.

As iTunes is downloading new items the connection to the NAS is reset, causing the download to fail.

If I copy manually then the process is VERY slow, and that too fails sometimes.

I have rebooted the drive but to no avail.

The firmware is up to date.

Any ideas why this is happening please?

I have read on reviews that after time the drive starts to fall off the network.


If the firmware is up to date, then perhaps you could try with a static IP configuration in the Dashboard in order to ensure the device will keep a set connection.


Perhaps I should, but as it was working fine before I am a bit confused as to why I need to spend ages trying to configure what is billed as a plug and play device. If I wanted to spend hours tinkering with it I would have bought a professional bit of kit.

I have disabled indexing and that has helped a little bit, but has not fixed the problem. Of course if the interface was even vaguely responsive I might be tempted to try, but as it isn’t…

It is not fit for purpose and is going back.

How are you copying from iTunes to NAS? Are you on wireless? Have you tried rebooting your router / switch?

I have tried on wireless and wired. I have rebooted everything plenty of times.

I have blamed my ISP, I have blamed iTunes, BUT when I remove the NAS from the equation, everything works very nicely.

Yesterday I turned OFF media server, iTunes server etc. and performance improved a lot, but it still the connection was reset.

It didn’t do this when I bought it.

If you can, do a system restore in Dashboard > Utilties.  This will format and reinstall the OS of the drive with the current firmware you have installed.  Also make sure you are only connected through wired (disable wireless) when you transfer files. 


I’ve sent the logs to a chap at WD and gone on holiday.

When I get back I may feel less inclined to use it as a Frisby (^_^)

I thought I would post an update.

I got back from a month away and tried again. Reset the system, turned OFF indexing etc. etc.

Woke up to find the drive spinning away like a mad thing - it was indexing again.

It was so busy I wasn’t even able to log on to turn it off.

So I had another go - reset etc.

Still playing up and essentially ususeable, so it’s gone back and I’ve bought something else.