CONNECTION REFUSED when trying to FTP from external IP


I own the 2TB WD My Cloud. I’ve enabled FTP, and am able to FTP to the IP address on the local network: e.g.; works great.

I am not able to FTP via my external IP address. e.g:  or

On my router, I have tried forwarding both ports 21 and 8021 to on port 21, but I always get a CONNECTION REFUSED response. My router seems to working fine, and is handling port forwarding properly otherwise.

My purchase decison was based on this funcationality, so any advice would be appreciated.

Thank you,


For pasive mode, you nave to open ports 5000-5099  in the router too. You can change the settings in /etc/vsftpd.conf via ssh.Install filezilla client for connect to mycloud. It´s the best option to connect it.

I did the following to fix my issue:

Enabled SSH on My Cloud

Used SFTP (with Filezilla) to login to My Cloud

Accessed /etc/vsftpd.conf

Added: (my public IP address)

pasv_min_port=XXXX (port range)
pasv_max_port=YYYY (port range)


Rebooted My Cloud

On my router:

I created a custom service, called it FTP_PASV

Forwarded XXXX-YYYY (my port range) on TCP/UDP to My Cloud


Through Filezilla, logged into my public IP. No problems.

Issue resolved.

Thanks Abelus!