Connection Refused when trying to "Check for new Firmware"

Have a NAS - MyBook World Edition 1 - model WD10000H1NC-00

When I click on “Check for new firmware” within the Web Interface, I get a “Connection Refused” message

I currently have the NAS connected directly to my iMac running OSX - El Captain via a direct ethernet cable

I bought this NAS a long time ago and it shows the following Firmware Information:

Description NAS Firmware
Version 01.02.12 with MioNet 4.3.1.13
Last Upgrade Sat, 17 Dec 2011 20:23:28

Hi @Fernando_Schaeffer - In a web-browser, what happens when you go to the link below: http://websupport.wdc.com/firmware/list.asp?type=wdh1nc&fw=01.00.02

Hi, it opens a web page with a “upgrade file” link
Should I click and download the file? Is it the right one for my NAS version?
thanks

No - that’s just a random firmware version (that is actually older than the one you have) - I wanted to make sure you weren’t being blocked from accessing the server which is what generally causes that specific error.

Do you still get the same error when updating from the device? It’s been a long time since I’ve seen the UI for the World Edition - does it put a URL into the bar, or is the error appearing in the device UI itself?

it actually downloaded file “wdhxnc-01.02.14.img” which I think it is a little newer than mine, as mine shows up as 01.02.12 with MioNet 4.3.1.13

but I did not executed it

the error appears in the device UI itself - this is the URL at the bar “http://169.254.126.231/admin/system_firmware_automated.php?lang=en” , but this is actually the URL of when I select System -> Update within the UI

OK that is a local page on the device that is throwing the error, not the actual download server. Let me check with our tech support guys in the morning and see if they’ve run across this before - in the interim, hopefully someone here comes up with a solution.