Connection refused to UI and private share

Dear all,

For the last month, I can not access the UI and private share of my My Book Live anymore. Unfortunately I did not make a recent backup of my important data so im really having a huge problem here. The device has been working fine for years and done its job well, was always left on.

However since the last couple of months, the above problem happened three times before. The first time, network settings in Windows 10 were mysteriously set to public and setting it back to private solved it. Second time, an apparent Windows update had disabled SMB and enabling the client/server boxes in Programs>Turn on/off Windows parts>support for SMB1.0/CIFS solved the problem. The third time, turning off and on the power of modem, pc and MBL solved the problem.

So now I’m stuck at the fourth time of the same issue. The MBL still acts like it always did, no signs that it is broken, no weird sounds, led light has the correct colours too. This time it happened while I was trying to solve an issue of my PC not detecting my android phone by USB connection. I had only changed some advised Windows 10 settings and had set each setting back when it didnt solve the problem. I also reinstalled Flash and Java. However whilst looking at the file explorer, I saw the connection to my private share disappearing too, the last thing I saw when clicking it was “empty”. The problem with the android phone was temporarily solved by trying to wipe the USB port clean (corona) after it was handled by a mobile phone helpdesk person.

In File Explorer, the MBL is visible as a Multimediadevice and as a Storage under Network. However it is no longer visible anymore as a PC. Mapping it didnt solve this.
Basically, I get connection refused by SMB when accessing in file explorer or run box (\192.xxx.xxx.xxx or \mybooklive). However, Windows log shows numerous Event ID 30803, showing that apparently it is not a SMB issue at all. In all mentions of the MBL in windows (eg devices menu, drivers etc) it is noted that the device works correctly but refuses connection. Same goes when trying to access the UI in any browser (http://192.xxx.xxx.xxx) or the WD Quick View menu. So apparently SMB and http connections are refused by the MBL server. The result is the same on Windows 7 on the same PC and Windows Vista, 7 and 10 on my laptop. The ISP even replaced the modem after on top of it all I had a very rare DHCP client error on my PC and no internet, but the issue remains. Same issue occurs when trying to access the MBL at someone else’s house.
Ftp and SSH were never enabled. The mediaserver works fine, I can access and copy all my media files.
Contacting WD servicedesk did not solve the issue either, for instance following their advice on https://support-en.wd.com/app/answers/detail/a_id/13466, changing all cables, powering on/off etc etc.
Using a port scanner, I found the following ports active:

Service Details
Port 111 (TCP) rpcbind
Port 548 (TCP) Netatalk 3.0.3 name: SANMyBookLive; protocol 3.3
Port 2049 (TCP) rpcbind
Port 2869 (TCP) NetFront Living Connect upnpd 2.3 UPnP 1.0; DLNADOC 1.50
Port 3689 (TCP) forked-daapd
Port 9978 (TCP)
Port 33478 (TCP)
Port 35919 (TCP)
Port 44547 (TCP)
Port 49154 (TCP) Portable SDK for UPnP devices 1.6.6 Linux 2.6.32.11-svn70860; UPnP 1.0

Summarising:

  • SMB is refused
  • Http is refused
  • AFP is enabled
  • NFS is enabled
  • mediaserver is enabled
  • FTP and SSH were never enabled

So I figured trying to access my private share with the MAC OS afp through port 548 was worth to try and hired a Macbook Air. And here we are now. Accessing the UI with Safari is still not possible, connection refused (http again?). Afp indeed works through Safari (afp://192.xxx.xxx.xxx) which redirects to Finder. I can now access the Public folders this way, and copy the data off it. I can also try to connect to a private share by typing a username and password however my username and password do not work. The username and password ought to be the same as the admin username and password. I do not recall ever having changed the password and not noting it down. I however tried all sorts of combinations and also the blank passwords such as " " “admin” or “none”, since I did a 4 second reset a couple of times.

WD Smartware correctly recognises the device. However, username and password do not work. Reinstalling the Windows Setup program does not work, it correctly identifies the device but reports there is a problem.

So I’m at a total loss at the moment and the last thing I would want is to open up the MBL and risking to loose my data. Are there any bright minds in here that can help me out recovering my data?

Any help is much appreciated!

Update 27-08-2020:
I’ve put the HDD in a HDD enclosure with SATA to USB and am very relieved to have finally been able to copy my data off of it that way. I also bought a bayless WD My Cloud EX2 Ultra with an extra 4TB HDD in the hope that I could use the MBL HDD in there. However, (surprise surprise) unfortunately the MBL HDD is not compatible with the WD My Cloud EX2 Ultra!! (https://support-en.wd.com/app/products/product-detail/p/130#WD_compatibility). In the meantime I also did a lot of reading on this forum and Google and found out that apparently the MBL is not secure anymore and can be easily hacked. Why weren’t customers properly warned about this high security risk?? So currently Im totally fed up with it and I dont see any reason to try to revive the MBL anymore, and plan to transplant its HDD in my PC as an internal drive. Such a pity of such a nice device! RIP.

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/23416