Connection issues with DNS-323 NAS

Searched a few places here and elsewhere that Google took me. Haven’t found what I’m looking for. I’m looking for help becuase I can’t get enough info out of the error message and as far as I know there’s no error log on the WDTV that I can access.

My WDTVLIVE can connect to a Windows and Mac computer on my network and play media with no issues.

I also have a DLink DNS-323 NAS on my network where I have been storing the majority of my media. Everythign was working great but maybe a month ago or so the WDTV stopped connecting to the DNS 323.

I’ve seen several messages while trying to figure it out, like Cannot find folders on network share, cannot connect to network device btu the latest one is invalid username and password.

A few days ago I downloaded the latest firware update hoping this would restore my ability to connect to the DNS-323. Sadly no.

I’ve restarted the WDTVLIVE and DNS-323 in serveral combinations as the rest of the internet suggests. 

I created a simple account on the DNS-323 connected with it from the windows and mac computer but not the WDTV.

I cleared all of the account info from the WDTV and even tried a hard reset but same results.

I pointed the finger a the DNS-323 for a while because out of the box it runs SMB services and by downloading an ad-on you can run NFS. So I thought maybe the NFS ad-on was not working properly. I’ve been trying to find a way to determine if NFS is working correctly. Haven’t found anything yet. As far as I know the Windows and Mac could be mapping those folders using SMB???

I believe the WDTV can connect using SMB but I’m not sure. It’s be great if there were a web UI to troubleshoot the WDTV or SSH to enable some sort of logging or debug mode. :frowning:

Anyone out there have any tips to figure out why it stopped working that I can try? I like it because I can play (or used to play) ISO and MKV and even MOD files which my video camera cranks out. 

Thanks guys for looking at this and for anyone who has something useful to suggest.

Did you tried to reset the router? 


I ve a DNS 320 and i also have wireless network issues after upgrading to thethe issues  latest firmware 1.0.43 v.

I have solved by

-attributing a fixed ip (fix in this forum) The last group of must be 264 (the 3 first depend on your network)

subnet etc…

-unhide ssid

my wireless usb dongle is a DLink DWA 160vA2 firmware 1.50E

My router is DIR 825

Hope this helps.