Connection and upload problems

I bought a 4T WD My Cloud last week and have been wrestling with it ever since. I managed to set it up and it worked at first, then it disappeared from the network and it was no longer possible to connect to it. I rebooted it and eventually had to reset it to be able to reconnect but I noticed that it kept switching IP addresses so I assigned it a static IP address and it has been fine for a few days. I started to upload a 140GByte directory with pictures and videos and this upload has been in progress since Monday however in the upload window a few files are listed as not being uploaded. Then kast night the upload stopped when the transfer was almost complete and now the drive is not visible on my network and I cannot connect to it. I therefore have a couple of questions:

* Why are certain files not uploaded? It is possible to copy these files to the WD drive in Windows Explorer and there is nothing that sets them apart from the other files that get uploaded (same format, file size and naming convention etc.).

* If the upload process chooses to drop the odd file like this, then how can I have confidence in this product as a file backup and storage solution?

* When/if I resume contact with the My Cloud drive, what will happen to the previous upload? Will it be resumed or will I have to start over from scratch? Will it recognise which files have already been uploaded?

* Has anybody any experience with an alternatice such as Synology as I am rapidly losing confidence in this product and am not too keen on spending more time messing about with it.

Best regards,


How do you upload your content? Best method is to map the target shares in Windows. On Mac, best method is to mount the shares through the SMB protocol. Using the WD Desktop app is not recommended for local network upload, but is the best option for remote upload. Using is plan C for remote upload, to be avoided for local network upload.

Hi and thanks for replying,

I use the desktop app which I thought would be the best method since it seemed to “promote itself” as the default way of doing this. When you say map target shares what do you mean by this?

The problem is that the connection to the My Cloud seems to get lost and then I can’t see the drive on the network, access it via the dashboard or get access remotely via my iPad or iPhone etc. I can reestablish contact with it but powering it on and off again and today I tried to upload more files with the same result that the upload stopped when it was almost complete and contact with the My Cloud was lost. I don’t see how mapping will solve this.




Sorry I don’t have the answer but I am hoping someone will as I am having similar issues. It works for a while and then just quits and to reconnect I have to turn the cloud drive off and then run set up to get it back…

Very frustrating…