Connecting WD my book with a generic sata to usb appears as unallocated

My HDD’s converter died and i took the case apart to connect the disk to my pc with a generic sata to usb but it doesn’t recognize the partitions in it and appears as unallocated

I tried EaseUS partition recovery as well as testdisk(albeit the windows version, not sure if linux would be any different) and it can’t find the partitions which has led me to believe that maybe they’re there but encrypted or something so can only be seen by the sata to usb that came with the disk

I’m unsure if there’s something i can do other that recuva to (try to) salvage the contents of the disk so i’ve came here in hopes you can help me

Maybe i could download the original software/driver/whatever that loaded the disk or something i don’t know, i tried some of the ones on this page to no avail, at this point i’m getting desperate

HDD is a my book essential, model WDBAAF0010HBK-01 if that’s of any help

Hi davidson23,

You should try contacting WD’s Technical Support about this for live assistance and troubleshooting

To Contact WD for Technical Support

The link below will allow you to call support


Create a Support Case
Create a support case with our world-class service and support team.