Connecting a USB drive to My Cloud

I took a brand-spanking new WD My Book 4 TB USB 3 and connected it to the My Cloud drive. I can see the drive in the dashboard but I get the message ‘Unable to create share’ with a code 1122. The only option presented in WD Quick View is to eject the drive. As anybody had any success connecting a USB 3 drive in this fashion.

Any help appreciated

Update to this problem…
I have tried a WD Passport 2TB USB 3 and that works…still no dice with the My Book 4 TB.


What is the file format on the 4TB drive?

 The WD My Cloud device supports the following formats for externally attached USB drives:


 NTFS (read and write capability)


 Linux Ext2, Ext3/Ext4


Another question, the 4 TB My Book, is a single unit or a dual drive?

Tried the WD 4 TB My Book on a different PC…it would not boot. Went to Futureshop to talk to their tech guy. One if the things he found was that in Disk Management, that drive was set to Offline, he changed that and the PC booted up (he also disabled in the BIOS the USB legacy support option).

Arrived home and connected the My Book drive to the My Cloud drive and it worked! I do not understand why a drive, straight out of the box, would have a status of ‘offline’.

Problem solved!

Curious.  “Offline” is not a status inherent to the disk.   “Offline” is just a status that Disk Management uses to indicate on of many possible conditions.  

I have the same issue. Putting a WD green 2TB into a external USB3 enclosure. I can see it in windows and write to it just fine, I can make NTFS partitions, exFAT partitions, I can break it up into 1TB chunks, etc. But the My Cloud will not see a partition on it. It shows the VIA labs USB controller, then a partition with 0KB available of 0KB. I had plans before I even bought My Cloud, to use this 2TB drive to back my NAS up. Thoughts?