Connecting a USB disk to NAS - Access Denied?


I’m trying to take advantage of the usb port on the NAS drive to add additional storage capacity to the NAS.

I have plugged in a USB hard drive and have done the following-

  1. Logged into the NAS
  2. I can see the external drive in the pane on the right
  3. Went to file sharing > Add a shared folder
  4. Followed the onscreen steps and added the USB drive
  5. I set permissions to Full Access for all 3 users (Everyone, admin, mwoody)

I can then browse to the NAS in a windows explorer window and see the new shared folder I created and can access the data on the USB hard disk itself through the NAS.

However if I try to write any data to the drive it just says access is denied.

I have tried a number of things to get this working with no luck and just upgraded the firmware to the latest version 02.00.18 but that didn’t help either!

CAn you please advise how to resolve the issue

FYI: I’m very computer literate and have worked with consumer hardware/software for many years so please dont dumb things down to much :slight_smile:

Thanks for your time

I’m having the same problem. I can read but can’t write to the USB attached drive (a WD Elements w/ NTFS) using any of my PCs (WinXP, Vista, or Win7). I upgraded my firmware to 02.00.19, but no change. Any ideas?

Problem appears to be that the World Book (Linux) doesn’t have a driver for writing to an NTFS external USB. Need to reformat the external USB as FAT32 or ext2.