Connected (Relay connection established)

Hi Guys,

I have setup port (80,443) forwarding on my cloud ex2 with static IP and DDNS to have remote access to dashboard.

Everything is working fine as expected, the connection status show as “Connected - Port forwarding connection established” for the past few days. However, today the connection show as “Relay connection established - Cannot establish remote access connection. Make sure you are connected to the internet.” even though I don’t have any problem connecting to the cloud using the app in my phone or remote access dashboard from external network.

I have tried rebooting the cloud drive but to no avail.

I have provided more information on the error nessage and configuration with screenshots below.

I’m not sure why I am still able to remote access dashboard and no problem accessing MyCloud app(iPhone) using external network even my Cloud Service Status show as OFF.

  1. It happens that my Cloud Service is Off and when I tried to turn it on it says that I’m not authorized to do so. I’m log in using admin account

Not authorized.jpg

  1. I have configured the port forwarding as below.

Port Forwarding 80.jpg

Port Forwarding 443.jpg

  1. Port Forwarding - Router N66U

Please let me know if I missed anything in my configuration.

Thank you very much!

I don’t use the relay service but it’s unclear why you are doing port forwarding on the EX2 itself? Why isn’t the port-forwarding on the router sufficient??

Ideally you should assign a static IP to your EX2 on your router and then setup port forwarding to the EX2. But even if you don’t assign static IP, you can still forward the port to whatever the IP of your EX2 may be at the time. But if EX2 is not assigned a static IP on the router, the IP can change and then the port forwarding becomes useless.

Hi Cybernut1, I’m using static IP address for all devices including EX2 which is the targetting IP of I have configured port forwarding on my router and EX2 at the same time because remote dashboard access will not work if I only configure port fowarding on my router which I have tested.

I noticed that when I remote access dashboard from external network the Cloud service connection status is Off with Relay connection but in the other end from the internal network the Cloud service connection status is on with Port forwarding connection established. So I’m not sure if I’m getting the correct cloud service connection status being show as Relay connection when doing remote dashboard access.