Connect to Network drive provided by Route (NAS)

Hi all,

I have a WD TV Live mediaplayer (new version newest firmware)

and observe the following issues:

- When connection Harddisk via USB and connecting this as share to my computer:

  If I download some files (via PC directly to the WD share) and playback (watch) some video from this drive at the same time, the system frequently looses the USB connection (=> asks me not to remove USB device without eject, but I did not remove it)

So I moved the harddisk as NAS to a router (TP-LINK  WDR4300) and tried to playback the files via Media server.

  • AVC  (H264) encoded MP4 video files are obviously streamed as “audio” files by the media server or detected as such by the WD media player.
      The picture is only seen in special menus of the media player where no background picture is displayed.

So I tried to access the NAS by its Network address from the router (\\volume1) directly.

  • However I cannot connect this drive from my media player. The Router/volume is not listed as Windowsnetwork and it is obviously not possible to provide the address to the networkdrive manually.

I am really frustrated because from 3 different options which I am willing to use, NONE works.

Any suggestions are welcome!


If you were using the back USB port on the WDTV, try using the one in the front. If that doesn’t help you can also connect the passport directly to the computer and share it from there.

1 Like

Hi  Alucardx23,

thanks for the hint. Using front USB was anyway on the list to be tested. I did this change now.

So far after this change no issue seen, but as it only occurs occaisionally I need some more time for testing.

Is this just an idea or have you read / experienced that this improves?

Of course it is “optically” nicer to use the back USB connection, but if it helps, I would do it.

Connection HDD to the PC is no option for me because I want to be able to access the Movies on HDD when the PC is turned of. (That’s why I was thinking to attach it to the router)


I have seen other users tried it, the problem seems to happen with USB 3.0, USB powered drives. 

1 Like