Connect to Netgear DUO from WDTV Live


#1

Hi.

Hope someone can help me with this problem. My setup is like this:

  • Windows 7 PC wired connection to router
  • WDTV Live with D-link wireless adapter
  • D-Link Router
  • Netgear Duo wired connection to router

This is my problem. If I share something from Win7 PC, I can access it from WDTV(network share). From my Win7 PC I can access both Duo and WDTV Live. But from the WDTV I can see the DUO as a unit in networkshares, but when I connect to it there is no question about username/password and all I see is a message “No media in currentfolder”. In frontview I have configured a username/password and enabled CFS service and set the default permissions to readonly access. But I don´t get why I don´t get the prompt for username/password and why I cant connect. When it´s working fine in all other directions.

Hope someone can help me.


#2

Try:  

In the WDTV Settings menu, go to NETWORK settings, and CLEAR LOGIN INFO FOR SHARES (or whatever it says)

and set REMEMBER LOGIN INFO to NO.

Give it a try.


#3

Sorry to say I already tried this. I thought this was the issue, but it didnt help. The only thing that happened was that I was prompted for username/password when connecting to my PC, but still no prompt for the Netgear DUO. Same message “No media in current folder”. I am going crazy over this, because I bought this NAS to have i especially for the WDTV as a medialibrary.

So please give me more suggestions and thanks for the try though.


#4

So, when you’re on your PC, and you go to Network Places, you see your DUO *AND* the folders that it’s sharing?

(I wish I could show you a picture of what I mean, but the Moderators might take a long time to approve pics).

So, I’ll describe with text:

Click ORB / Computer

In the LEFT Navigation Tree, scroll down to NETWORK and click the chevron to the left.

You should see your NAS.

Now click the chevron next to the NAS, and you should see your share listed.

If it asks you to LOG ON then, then use the same credentials you use on the WDTV.  

If the share shows then, then we’ll have to think of something else.

If it DOESN’T show, then it’s a Private share.


#5

Answer to your question: Yes, I can browse the DUO from my PC without any problems.

From my PC to Netgear DUO I got promted with user/pass the first time and I checked the “remember”-box, and I have no problem accessing the shared folder in my DUO(I only got 1 mainfolder with subfolders in it). When I browsed my computers “Share” first time from WDTV I got prompted as I should. But the problem is when I try to browse the Netgear DUO(that shows up as a Network Share in WDTV) I get no prompt for user/pass. It only shows the “No media in current folder” message. This is really strange, because it´s impossible for the wdtv to access anything on my NAS without user/pass. So I think it´s some sort of “fake” message. It´s not really connected. But the question is why it doesn´t try to connect, when I can access my PC:s share without any problem.


#6

Check to see if your DUO has “Guest” accounts turned on.

If it does, DISABLE it.

I seem to remember that my QNAP does the same thing if I have GUEST turned on.   But that was a few weeks ago that I set it up, so I can’t remember.


#7

By Guest account i guess you are talking about  the “allow guest access” under the share security settings? Yes it is turned of.

Added info: I resetted the credentials to log in from my PC to the Netgear and instead loged in with the usernamn/password that the wdtv should use, and it worked flawless. I got “read-only” access to everything shared, like it should be. Normally I log in with the admin account from my PC to have full access to the NAS. So now I doublechecked that it´s not a problem with the user/pass thats causing this. So what could it be…


#8

My only guess is that the DUO isn’t advertising the shares correctly. 

On your PC, BEFORE you log in to the NAS, type the command

NET VIEW  \[server name]\  where server name is the network name you’ve given your DUO.

It should give you something like this:

C:&gt;net view \bignas1</font>

Shared resources at \bignas1<br>


Big Freakin’ NAS Server 1


Share name             Type  Used as  Comment
-------------------------------------------------------------------------------

ISOs                   Disk           ISO Repository

Movies 1               Disk           Kid Safe Movies

Movies 2               Disk

Public                 Disk           System default share

TV Shows               Disk


The command completed successfully.


C:&gt;

If you’re not seeing your shares, then the issue is with the NAS.

When the Kids’ WDTV logs in, they only see “TV Shows” and “Movies 1”.   

When I log in, it sees those plus “Movies 2.”

When I log in from the PC using admin creds, I see them all.

If you do, then maybe there’s some illegal characters mussing up the works.


#9

Hi tried the command. No problem to see the shares. It instantly shows the shares as it should.

So from PC no problem at all to connect. I tried to log in as “wdtv” wich is the account the wdtv should use, and that works as it should too.

So I guess the problem isn´t with the duo then.

But what could be causing this. Because from WDTV I see all shares from PC and can browse them without a problem. But when I chose the Netgear the wdtv shows the “thinking”-icon and after a while the “no media in current folder shows”. I tried the clear log in info and did a factory reset too. No luck, no log in prompt at the netgear, only the PC gives that…


#10

Sorry, I’m out of ideas… :frowning:


#11

I have the same problem with another NAS. In my case I use the Addonics NAS2UX2, but i have the same problem.

The bad news is that i havent solved the problem yet. I dont know what to do.

If someone finds a solution, I ask you to tell it here. Thank you very much.


#12

Welcome to the forums.

If the beta firmware for the Live is still available you should install and try that to see if it fixes your issue.


#13

Hi.

I just wanted to share my solution(a workaround, because the solution is not found yet).

The problem for me was that I didn´t get prompted for username/password on the WDTV Live and because of that I couldn´t connect and see the shares on my NetGear Duo. And I didn´t want to open up the share on the DUO for all users(=public sharing). So my solution, that worked with the WDTV, was to enable “Guest”-access. But to get the security I wanted, I limited the IP-adresses to connect to only include the WDTV:s IP and my computers. And I set all security settings on the share(CIFS) to be “read-only” as default. To workaround the issue to be able to delete,add, etc from my computer I just connects with the built in Admin account. That way I don´t need any special users created in the NetGear Duo.

After I enabled guestaccess as told before, my WDTV connected immediatly and I could see all shared folders.

It´s rather strange that the WDTV can´t get the login prompt from the NAS, but I guess there is some sort of compability issue between the units.

Hope this helps if someone else have this issue.

Just ask if u need more details about the setup.