Connect My Cloud to computer

I have been trying to connect My Cloud to my Windows 10 computer network. I searched and followed all steps to set it up with Static IP, but never work, and always have to 40 sec reset and start again. I even reserved an IP address in my router, Netgear R7000, with the MAC of the cloud, used that specific IP address and still nothing
my set up ends been
192—.100 (reserved IP)
255.255.255.0
192—.1 gateway (Router LAN IP)
192—.1 same as DNS
I have tried just with the first two only and nothing. It looks that everything is as instructed but still doesn’t work. Any ideas?
thanks

Is the My Cloud connected, via Ethernet cable, directly to the Netgear router?

Can you access the Netgear router and see what IP address it is handing out to the My Cloud?

If the computer is connected to the Netgear router wirelessly, check the Netgear settings to ensure the wireless devices are on the same IP subnet as the My Cloud and that WiFi isolation or similar setting isn’t enabled which would block a WiFi device from accessing a wired device on the local network.

no, now the My Cloud is connected to the computer via cable. I assigned an specific IP address in the Netgear router for the MAC address of the My Cloud.

I found in another thread an explication for connecting via Static and Dynamic IP. The static method is quite similar to what I was doing, so I tried the dynamic version, which is more simple and it worked fine.

thread:

thank you guys

Is that by Ethernet cable? Does it show on the computer as another drive?

yes, Ethernet cable, and should show in the Network list on the computer as MyCloud, if that’s how you still have it named, with the MyCloud icon. As the method in the link I posted to the other thread mention, you disconnect the computer from internet and connect it to the Mycloud, and turn it on, follow the steps on when to connect the Ethernet cable and after set your sharing network option to private network, it should show then. Follow the steps in that link.
the only difference is that I shutdown the MyCloud(http://wdmycloud/UI/) while connected to the computer not the router(because my desktop computer has WIFI, so I was using WIFI for internet, Ethernet cable with the My Cloud), but the idea is that it should be off, and you star it up when you are next to the computer(computer OFF the internet), wait for it to process the start, blinking light, and then connect the Ethernet cable, set the network sharing to private network, and voila, the Mycloud will be visible in “Network” in the file explorer.

Is the computer connected to the Netgear router? IF so how? Wifi, Ethernet, other?

Generally if you have connected the My Cloud direct to the computer it WILL NOT obtain an IP address from the network router unless you bridge the computer network port the My Cloud is connected to, to a second network port on the computer that is connected to the network router.

@navarrete72 You may want to look at this and try it. I believe this was written for the 1st generation My Cloud, Firmware 04.xx.xx. Hope it helps.

https://www.jabari-holder.com/blog/wd-my-cloud-ethernet-direct-connection-and-fixes/

it’s connected through Wifi, the Ethernet I’m using it for the My Cloud, probably that’s my issue with the static version, but I used the Dynamic method of connection and worked fine, less changes to make

Thanks, Cat0w, it’s kind of similar to the Dynamic IP connection that I mentioned, but it’s a good suggestion what they mentioned about searching in the explorer using the network name of the My Cloud.

I’m just trying to go around of all the issues of windows 10 with the My cloud by connecting it directly to computer, now Windows 10 screwed up the partition of my HDD, so my backup in the My cloud is what I have