Connect My Book World Edition (MBWE) II to Time Machine on OS 10.7 (Lion)

MBWE seems to have had no issue connecting to Time Machine with the default password setup.  After changing the admin and WD_Backup (Time Machine User) passwords, the connection to Time Machine was no longer active.  

After restarting the MAC it was common to receive a MyBook error that notified you that there was an issue connecting to the NAS Server.  To resolve these issues and maintain a solid and stable connection with Time Machine and the NAS for general storage access do the following:

Clear Default MyBook Connection from Start-up:

  1. Open System Preferences,
  2. Select “Users & Groups”,
  3. Select “Login Items” tab from your default or preferred user,
  4. Remove Item “Public” by selecting the " - " sign at the bottom of the list  (remove this item if you experience connection issues on restart/start-up)
  5. If you’ve removed “Public” item from “Login Items” go to: Finder > Go > Connect to Server (see next sections for user setup).

Setup User: admin (cont’ from step 5 if you’ve followed step 4)

  1. “Connect to Server” using afp with MyBook’s default IP address:  192.168.0.100, if you’ve altered it, adjust IP to your alteration.
  2. Under “Server Address” type the following:   afp://admin@192.168.0.100/Public
  3. You will be prompted for your admin user password.
  4. Enter your password and check “remember to password keychain”.
  5. Once connected return to:  System Preferences > Users & Groups > Login Items.
  6. Add the “Public” mounted drive to “Login Items” by selecting “+” and browsing to the volume.
  7. You’re admin user is now setup for start-up!

Setup User: WD_Backup (setting up Time Machine)

  1. “Connect to Server” using afp with MyBook’s default IP address:  192.168.0.100, if you’ve altered it, adjust IP to your alteration.
  2. Under “Server Address” type the following: afp://WD_Backup@192.168.0.100
  3. You will be prompted for you WD_Backup user password.
  4. Enter your password and check “remember to password keychain”.
  5. Once connected go to:  System Preferences > Time Machine > Select Disk,
  6. Select the “WD_Backup” disk and complete your Time Machine Setup.

The following steps have resolved all connection issues experienced with MBWE II.  Time Machine works flawlessly and MyBook always connects correctly on start-up.  Hope this helps, good luck!

3 Likes

This is helpful, I think mods should make this thread a sticky.

2 Likes

O yes, I agree with you pizza, this is useful.

I was excited to see this solution, but unfortunately it is not working for me. 

I don’t have the default MyBook connection as described in section 1

I followed all the steps in the second 2 sections but I still cannot connect as WD_Backup to the NAS for Time Machine.

It just refuses to work. 

Help!

Are you having a time machine or admin user issue? I can attempt to help but you’ll need to be more elaborate in describing the issue. Please let me know what happens when you start-up.

Sorry, I’m a bit wasted. You’re having a time machine issue. Log into your my books via browser using its IP. Go to users > WD_Backup. Setup a password by selecting the check box. Once you’re ready, restart your machine. Follow step 3 in the tutorial using the password you specified for WD_Backup.

for some reason the web interface for the MBWEII is not allowing me to change the password for WD_Backup.

this is so frustrating!

thanks anyway for help, advice, etc… 

Did you change your admin password from the default? If not change it by going: Advanced > System > Admin Password

no issues with the admin password. i did change it when i first hooked up the MBWEII. I can log in, but am unable to save a new password for the Time Machine user.

Turn off Time Machine. Connect to WD_Backup. Turn on Time Machine > Select Drive. Choose the mounted Drive.

i cannot connect to WD_Backup through finder, and as a result cannot connect through Time Machine.

I’m having the same problem as Anthi. Time Machine doesn’t mount my WD_Backup using my previous password and when I try to change the password through admin access, I can’t successfully change my user password for WD_Backup User. I keep getting the error Failed to modify user.

After I try to “connect to server” I receive a message saying there was a problem connecting to the server. I have not changed any settings. What do I do?