Confused about USB Backup

Using a relatively new MyCloud Ultra EX4 and wanting to backup the files stored on it. Therefore, I attached an external USB drive of equal capacity, which is formatted using the NTFS type of file system. Then I set up a backup job as described in the User Manual. The job ran fine and appears to have backed up everything. However, it now appears as though nothing else happens until another backup job is requested to be run by the administrator. Insofar as backup is something that needs to be done periodically in order to include new and possibly revised files I tried to run the backup job again after a period of time where a few more files were added. The subsequent backup fails saying that the destination folder is set to read only. I thought maybe I needed to change the backup type to something other than “Copy” even though based on the description “Copy” is what it appears that I want. The description says, “Copies files from source to destination. Duplicate files will not be overwritten.”. Based on said description I do NOT want either “Synchronize” or “Incremental”.

I wasn’t able to find any information in the User Manual about the Type option for backup jobs. Is there some other source which might elaborate on how this type of backup scheme is supposed to work?

I’d be most grateful if someone could explain what I’m doing wrong.

Did you check the below article for USB Backup of My Cloud?

Yes I did review that article prior to posting my topic. As indicated in my post that job worked as expected the first time. However, after that it fails saying that the destination is read-only. Insofar as the destination was created by the initial backup job, it does NOT appear as though I’m responsible for creating that affect. Before I start hacking around with Windows permissions on a NAS/SMB device I thought I should seek assistance from those with more experience and expertise. It is hard to imagine that I’m the first one to experience this phenomenon.

  Note:  I did make an error on my original post.  The device is a My Cloud EX2 Ultra rather than 4X.  Sorry about that.

I could never get it to work properly.

Something I’ve considered is that while the documentation lists a bunch of different filesystems as supported there are differences in the way they function. This is particularly true in relation to permissions.

I elected to format the USB device I’m using for backup as NTFS. My reason had to do with the ease with which I could access the USB device from other computers. However, the “read-only” condition is something that is a bit peculiar to NTFS. Therefore, I thought it might be worth trying EXT4 which is what, I think, the My Cloud uses when it formats a drive. In that, the data being backed up is stored in an EXT4 type of file system.

What file system has “ak988” used for the USB device? Does anyone know if the choice of file system is relevant?

The drive obtained for use as backup media has now been converted from NTFS to EXT4 format. After some glitches associated with the way USB shares seem to function it now appears that the problem concerning the inability to rerun the backup job successfully is solved.

This leads to a preliminary conclusion that NTFS partitions ought NOT be used as the target for NAS to USB backup. Insofar as the other Windows compatible file systems (i.e., FAT & FAT32) are not really suitable for large capacity partitions this more or less implies that EXT type file systems are what should be used for the target of such backup jobs.