Configurator doesn't accept admin password

I bought a G Raid with Thunderbolt 3 20TB drive. I want to configure it as RAID 1. I downloaded configurator 1.1.52 (I found the link to it in another thread…no idea if it’s the most recent as I can’t find the actual download page that contains this software).

It wants my admin password but rejects it. I tried changing the admin password to something simple (aaaa) as suggested in another thread but that didn’t help.

Any suggestions?

Thanks,

David

I figured this out. Unlike basically every other piece of Mac software, the configurator doesn’t ask for admin account name, only password. It turns out that it’s assuming the account you’re installing from is the admin account. So neither the admin password (which is for a different account), nor the account password for the non-admin account (which obviously doesn’t grant admin privileges) will get the job done. I ran the configurator inside the admin account and it worked.

One thing I still don’t know is how to find this software by searching the WD or G Technologies web sites…I was lucky enough to find a link to it in a response in this forum. Can’t even tell if I have the latest version…