"configuration system failed to initialize" Windows 10

WD Smartware had been running fine for months. After I had to manually shut down my XPS 8700 Windows 10 (64bit) I restarted WD Smart flashed the error “configuration system failed to initialize” - very hard to read the error because it blinked less than a half second.
(What follows is the solution, discover, probable cause, and situation situation today).

I searched WD Community and my first result showed one topic that was close. It was not until I could copy the error “configuration system failed to initialize” did I discover this happened in 2013 on Windows 8. It helped in my keyword search. It is worth a read as the solution proposed solved the problem. The cause is not clear to me. As in 2013 the solution is not just use uninstall utility (WD or the operating system) and reinstall. This is what the well meaning support tech told me on the phone yesterday. No fault, just does not know of this unique issue.

It turns out the uninstall left the file user.config in place, as in 2013, the re-install created another user.config. In my case the user.config was not empty. WD Smartware could not work with these two. So as was suggested for windows 8 by JeanLeon:
“I figured it out: there was an empty user.config file in the appdata folder, I deleted it, and it now is running…”
This solution worked for me to get WD Smartware working.

As ejgemperline stated in part: “…I went out to Users/xxxxx/appdata/local/ …found three Western Digital folders all dated …the date installed … initially; …deleted the Western Digital software, went back to appdata and found the folders still there. I figure someone from WD must have forgotten to delete those files when uninstalling the software. I deleted all three files, reinstalled the software … WD needs to fix its uninstall software as well as Smart Ware so that it can survive a manual shut down of the computer.”

As of 20170407 Version: 2.4.16 Release Date: 6/21/2016 and File Size: 42 MB this issue is still outstanding

The forum helped me solve the problem once I got the optimum search terms

1 Like

This may correct this problem too.

A person can right click on Start>Control Panel>(Programs) Uninstall a program then scroll down and choose WD SmartWare, then select Repair at the top.

Please refer to the link to resolve the issue
Error: ‘Configuration system failed to initialize’ when attempting to launch WD SmartWare