Computer won't let me set up my new internal HDD

OK, I just bought a 4TB internal drive (WD40EZRX-00SPEB0) to use as the second drive on my Windows 7 64-bit system.  I plug it in and boot up, of course, it doesn’t show up on Windows Explorer.  It does show up in Device Manager, with that little yellow triangle and bang.  When I click on it, the device status is “The drivers for this device are not installed.  (Code 28)   Access is Denied.  etc.” 

When I try to follow the directions that I found online and try Disk Management, the disk is nowhere to be seen.

What am I doing wrong?  I’ve worked it on for a few hours and made no headway.  I’m no computer expert, but I can follow simple directions.

Hi does your motherboard bios support a 4tb drive. So if not the first thing you need to do is get bios to see the drive until then you can do nothing with it. Let us know what board you have.

Thanks for the quick response,

My BIOS verions number is 0803, bulid date 3/31/11.  I see on the ASUS web site that are are 8 revs since the.  I am trying to update the BIOS, but the updater program keeps telling me that that updater is incompatible with my 64-bit system - even though I got the updater from the W7-64 section.  I sent ASUS an email to see what is what.  I’ll let you know when I get that done.

Ok no problem I imagine a bios update should sort it. Remember when you go to flash the bios the system can not lose power nor can you halt it half way through.

OK, I have upgraded the BIOS and am still having problems.

Everything seems about the same.  I can see the disk in the BIOS startup.  When I go into cmd and check diskpart, it can’t see the HDD. The HDD also does not show up on Disk Manager. It does show up on Device Manager with that little yellow triangle. It says, “The drivers for this device are not installed. (Code 28) Access is denied. …” I tried search automatically for a driver - that failed and now the HDD is listed under “Other devices.”

Most of the installation instructions that I find are for using it as the boot HDD.  I want to use this as the second HDD.   The few instructions that I find to fit my situation fall apart once I get to Disk Manager and they assume that I can see the HDD there.  I’ve unplugged the new HDD, rebooted, shut down, cleaned the connections and reconnected and rebooted and still have this problem. 

What do I try next?


I tried to update the driver and had it search the Windows diretory (WD says that the drivers should already be there) and I get, “Windows found driver software for your device but encountered an error while attempting to install it.  -  Disk drive - Access is denied.”

Again with the “Access is denied.”