Computer won't boot

My computer won’t boot with the new drive connected. I have to disconnect it, boot up then reconnect.


To boot the system with the drive you need to make the new drive the bootable one.

How do I do that?

I also have the same problem, after I connected my new WD Elements 1TB drive my Windows 10 PC failed to boot, I have to disconnect the drive re-boot and then once Windows is started I can use the drive. This is unacceptable, I have checked and have all the latest Windows drivers and once the drive is up and running it is not showing any errors. Has anybody got an answer for this problem?
I tried the drive on a Windows 10 laptop running older versions of the Microsoft Disk.sys driver and the drive works perfectly and does not stop the laptop from booting up. So it seems to me its a problem of the MS drivers!!!

You have to re-format the external drive to NTFS.

Hi Fishkillbill
Thanks for your prompt reply, unfortunately I already tried that, still does not work, I beleive its something wrong with the drive, I have replaced it today with a WD My Passport 1TB drive that worked perfectly just out of the box.

I have the same problem with a 4TB MyBook. My pc doesn’t post even with the drive connected. Once the pc is up and Windows (7, 64bit) has finished loading, I can connect the drive and use it.

Check the Boot settings in the BIOS. You don’t want USB first.

post=power on self test.
With the external drive connected, the fans start spinning an the lights come on when turning the computer on but it doesn’t get to the point where I can get in the bios. It just sits there.
Anyway, I had a chance to put that external drive on another pc and that one boots just fine. So I’m inclined to think there’s something fishy with the motherboard.