Computer Does Not Recognize My Drive Anymore

I bought a My Passport Essential and installed it, along with the Smartware software, on my old Dell desktop with Windows XP. Right away I noticed signs that it was slowing down my computer, so I deleted it thinking I could just drag and drop and copy and paste. Right after I deleted it, I wasn’t able to access my drive at all. When I plugged it in, it did not recognize it. I’ve tried a number of things to get it to work again. I’d like to use for its storage and not as a paper weight. If you have any ideas for me, that’d be great! Thanks

Hi there, while the software was installed, did you create a password? If so the drive keeps the envryption even when the software is removed…

On the other hand, did you check if the drivers are still present on your computer on device manager? Or is the drive seen on disk management (right-click my computer > manage> disk management)?

Actually it does show up in there! What do I do now?

Good! Now how is it shown? Healthy? Raw? Unallocated? With a blue box? With a black box? o.o

It’s here under device manager but does not appear under disk management or anything else.  This is the only place I’ve seen it WDMyPassport_ComputerManagement.JPG

Hello,

Please help.

I have a similar problem… I deleted all folders and files that were on the drive originally now  I can’t see the drive with any computer. What can I do?

Can you post a screen capture of your disk manager window?

1.jpg

It still wont let me access it. It wont even recognize it.

Exact same situation here.  I deleted the files w/ the WD Smartware utility and now the drive is no longer working.  When connected to my PC it continuously churns and essentially locks up Windows until I unplug the WD drive.

I have the same situation. The Device was working fine. I can see it in Devices on Control Panel. However, no shortcut …not seen on my computer …however there is a tab for it on remove devices…

So… No one has even tried to offer a solution… Great forum!!!

The WD Community was created for Users, such as yourself, to help one another, and to share your experiences and ideas with one another. If no one reply your questions perhaps they don’t have the solution, if you are looking for technical support from WD, you will need to contact them directly.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

I had a simlar problem with my passport yesterday…

It worked fine until I left it plugged into my laptop over night. Didn’t recognize it the next day, just said after like waiting 3 minutes that the drive needed to be formatted in order to work with windows again. It popped up in the device manager, but wasn’t shown in the My Computer section at all. Trying to format the thing just got me several error messages, but no solution.

So here is what worked for me.

I went into the device manager into the disk drives section where the WD Passport was shown and disabled the passport completely, not uninstalled it, but disabled it. Then I unplugged the passport and rebooted the laptop in order to let the change in the hardware settings take effect. After the reboot, I plugged in the passport, waited like 5 minutes and re-enabled it via the device manager and it finally popped up with the autorun stuff and everything else.

Did a firmware update after this and now it runs perfectly fine again.

I hope this helps some of the people with the same problem.

What you experienced was probably a result of the laptop/pc going into hibernation while the drive is still getting power from the USB.  You can either restart the pc, or just disconnect and reconnect the USB cable.  Most likely the drive is asleep anyway, so you shouldn’t hurt the data.  If you’re concerned about corrupting data, just restart the computer.