Component Video issues (too dark picture)


I have a problem with my WD TV Live, hooked up to a video-projector via component cable.

The problem is, that the picture is way too dark for 720p and 1080i - the brightness however is correct for 576p (and maybe 480p - didn’t try).

I tried both - YUV and RGB - but that didn’t make any difference at all.

The dark picture can’t be fixed by turning up the brightness on the projector - the color information is lost (dark areas become completely black! In dark scenes often you can only see the lit half of the face)

I have the newest firmware installed, which fixed the “red eared” people issue (wrong color conversion for most HD content).

Hmmmm. This is a new one. Can you post a MediaInfo from the files that don’t work? I don’t have this issue, and I’m plugged in component as well… This may be a dumb question, but are you sure you have the WDTV set to COMPONENT? (it will often work through component, as well, even if set to HDMI.)

Yes, I did set it to component:

Settings -> Audio/Video -> Component -> (tried all different choices) --> (tried YUV / RGB, no change) --> clicked OK

I did some testing with SD-material and jpg-images. it seems that the bug only affects HD-content (all HD-videos I tried).

here is the media info (hope I used the right program) for  one file that has the problems:

Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 8 frames
Muxing mode : Container profile=Unknown@5.1
Duration : 1h 58mn
Bit rate : 6 087 Kbps
Nominal bit rate : 6 237 Kbps
Width : 1 280 pixels
Height : 688 pixels
Display aspect ratio : 1.860
Frame rate : 23.976 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.288
Stream size : 5.06 GiB (79%)
Writing library : x264 core 57 svn-709C
Encoding settings : cabac=1 / ref=5 / deblock=0:0:0 / analyse=0x3:0x2 / me=hex / fpel_cmp=sad / subme=6 / me-prepass=0 / brdo=0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / bime=1 / keyint=150 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=6237 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30
Language : English

looked a movie again yesterday, which had lots of dark scenes…in 576p.

the dark areas where too dark, and had a greenish-blue hue.

not happy with the wdtv live at all - if there is no solution, it’s going back to the reseller, or to ebay.


looked the movie at 576p, I told you it works OK in that resolution. apparently I was wrong and it’s only a bit better.

That’s an odd resolution – are you on a PAL system?

If so, it might also be a PAL versus NTSC issue (way outta my league there).

I’m using an Optoma DS-302 video projector. it supports both, PAL and NTSC. (I guess there was just one model for the whole world)

576p is supported only on PAL / SECAM systems.  

Do you not have to change a setting in the projector when changing formats?

Component is component. Afaik there is no different color-encoding for different resolutions. I also tried out all different resolutions. 480p doesn’t look any better either.