Compiling Media Library

I’m new to the forums, though I’ve made use of them many times over the past few months…

A little background - I’ve got two Live Hubs now (started with one in the gameroom, and found the interface and usability so much easier for my family than my old Revo with XBMC that I got a second for our living room).  I have about 100 videos loaded on each (I found local storage was the easiest solution for me), and have been using them primarily to watch movies and TV Shows for some time.  I’ve never had any issues with the Library Compiling properly… until now.

I decided to finally clean up my iTunes library and get it loaded up on the LiveHub.  I found a great tutorial on Lifehacker regarding how to setup an OSX automator workflow to sync your iTunes library, which really eliminated my hesitation about having to keep up with everything manually.  

That said - after loading my 1600+ songs, the library continues to compile.  I first let it go overnight and throughout the day (probably 20 hours +) with no stopping - no luck.  I logged into the web interface for the box and can see the TWONKY Server see’s all of my music and movies listed and I can launch them from that interface without issue.  In fact, I can see in the config area of the TWONKY server when it’s actually building the library (it tells you the progress, the current file it’s logging, and the last database modification), and when it has completed the Library Compiling (usually in about 10 minutes) - but the box just sits there blinking at me, taunting me.  

Any ideas?  I’ve tried turning off the Media Library and clearing the database a number of times - to no avail.  I’ve tried restarting the compile from the TWONKY side, same result.  Also, after playing with it, I notice the fact that I even have the “clear media library” option available SHOULD indicate that the library has been compiled (I have noticed when I go into that menu while the box is re-compiling, that option doesn’t exist at all), so I’m confused.   

Has anyone corrected this?  Any suggestions?  I feel like I’m taking crazy pills.


Anyone?  Anyone?

I have had a continuous compiling issue as well earlier this week.

What worked for me is:

  1. turn off media library.

  2. Clear Media Library

  3. pull the network cable and power cable from the back [not just the power button]

  4. wait 5 seconds and put back in power button cable only

  5. turn on media library and wait for internal to finish compiling. Shouldnt take more than 30 minutes [mine took 5 mins as I only have 91G so far]

  6. When done compiling, plug in network cable to compile external devices

No idea what happened, but it just started working all of the sudden last night.  I was actually just trying to generate a decent log file, and through the course of rebooting, powering off, powering on, etc - I just happened to notice it had stopped blinking.

Everything seems perfect now.  Strange.