Compiling Media Library on a NAS Share using SMP seems to be a Never Ending Process!

Hi All,

I have been trying on and on to setup my SMP in a way that it can finish Media Library compiling on a NAS Share  for more than over 3 weeks now!!!

I have tried several recommendations that I have got from the WD community forum, special those proposed by TonyPh12345  ,who I believe to be a very experienced user of  the WDTVLive platforms.

It should not be so difficult as it turned to be, since my network setup is as simple as this:

  • WDTVLive SMP (latest firmware available) is wired (or wireless - I have tried both) to my Router (Gigabit Ethernet and Wireless N)

  • IOmega 2TB (also Gigabit Ethernet) wired to same Router

  • NAS Shares with total free access to Everyone on the Network (I have tried also specific  permissions for SMP)

  • Initial tested on a Share containing 500GB of Movies (organized on folders)

  • Also tested on a  Sample Share using only 3 Movies without any Folder organization (same results)


  • Content-Addressable Files (.CAS) created by the Network protocol whenever I add a Share to be compiled

  • Never managed to end the process ( independently of the NAS Share I have chose) and even waiting for it running for more then 24h.

  •  Only a couple times I had hope the process had a successful finish (when SMP stopped blinking the front Led) but I have realized that SMP system blocked or  when I tried to access Media Library I got the message " Last Content Source has been Removed"

  • SMP Reset to factory default without any relevant progress

After reading almost all the relevant info published by WD or in this Forum, I have decided to email the subject to WD and to post my case here in the Forum, hoping that some of the members of the WD Community (and seems I am not the only one having the same problem) can lead me to the solution of this issue.

Thx in advance to all contributions!

There’s been a long-standing issue with some people whose media libararies never seem to finish compiling.

It’s been this way since the dawn of the Hub, which was the first platform to support it.

No one has yet tracked down the root cause.

I can offer only some guesses, and a way to possibly troubleshoot the issue, though it may be tedious and time consuming.

The only guess I have is that one or more of your media files contains internal metadata that the Hub/SMP are choking on.  Only way to validate this is to find the file(s) and then we can dig into the file and see if we can find the issue. 

  1.  Try adding the media in small doses.   Start with an EMPTY share, with only a handful of files in it.

  2.  Reboot the WD and see if the Library compiles.

  3.  Add more files (maybe 10% at a time?) to the share.   Repeat step 2.

… if you ever get to a point where the box starts “failing” to compile again, it’s reasonable to suspect that the last batch of files contains the issue.  Remove SOME of the files that were last added.   Repeat Step 2.   … and keep removing files until the problem disappears.

By this, you might be able to find which file is causing the compiler process to hang.

Thx for your prompt reply and suggestion.

In fact I have already created a a Media Library concerning all those movies but that happen only when they were presented to the SMP directly on a USB drive!

So, it seems to be not a file related isse but a Network handling issue!

However I have also creted a NAS “SAMPLE” Share containing only 3 movies and some Metadata info files and backdrops concerning only those 3 movies.

The results were the same…hours have already passed and the process have apparently no progress after the creation of the .Cas files, despite the SMP giving me the indication that the process is continuing…

Any other guesse will be welcomed! 

Only another piece of info related with this issue that can help you understand this issue is whenever I try to access the Media Library (when the process apparentely is still on progress) I allways get the message: " Last content Source has been removed"

Yeah, that’s a “normal,” if not entirely accurate error message, for the state you describe…  If the compiler has seized up, and you try to switch to the media library, it can throw that error.

It will also tell you that if it cannot access the media library database files due to missing data, corrupt database, etc.

Well but also seems to have some inconsistency issues because if the message is correct, then the process should stop (no content source, should mean nothing to scan - as it happens when I remove the NAS from the network, shutting it down, the Led stops and the Compiling message terminates).

Another inconsistency message is if I try  to access the Media library again , then I got the following message:

“The WDTV is scanning your content. Media will not appear until it is scanned…” having the options to “Wait” or “Folder View”. if I choose either “Wait” or “Folder View” SMP returns to main Menu and nothing else happens ( The scanning apparently  continues…).

Excalibur wrote:


Another inconsistency message is if I try  to access the Media library again , then I got the following message:


“The WDTV is scanning your content. Media will not appear until it is scanned…” having the options to “Wait” or “Folder View”. if I choose either “Wait” or “Folder View” SMP returns to main Menu and nothing else happens ( The scanning apparently  continues…).


Yeah, that’s also indicitative of a corrupted database or crashed compiler.

If you do “Folder View,” the content source should switch to “DISK,” and you’ll just see folders with no tie-in to the media library.

If you do “Wait,” you’ll be switched into the Media Library, but it’s hard to use because it will constantly be updating the screen contents, and the arrow will spin every few seconds…   This mode isn’t useful at all.  ;)

Has anyone found a solution or some light towards a solution to this problem?

I have rolled back to the previous firmware without any progress…

All contributions are welcomed!

thx in advance

P.S. I have noticed this problem was already reported to WD in the ISSUE REPORTING thread, but we are still waiting for WD feedback…

I started getting weirdness immediately after the 1.5 update on my SMB share.  The library just never would finish building. 

From a computer on the network, I accessed the share, deleted the .wd_tv folder, then did a search for *.backdrop, *.metathumb, and *.xml and deleted all of them that were WD files. …just be careful to delete only the WD xml files.  You might start with just the .wdtv folder; it’s easiest. 

Once I let it rebuild, it seems to be better.  …no more hangups while compiling library. 

I have all my Bluray ripped directly to folders on my SMB share straight from anydvdhd.  Before the 1.5 update, the metadata worked fine.  I could scroll across the movie folders and all the metadata showed up.  Ever since the 1.5 update, I only see metadata when I drill into the folder all the way to the stream folder. It seems I have to convert all my folders to .iso or .mkv and clutter all the metadata in one big flat folder in order to see metadata.  What a mess!

2 steps forward and 3 steps back with each firmware update.