"Compiling Media Library..." every time i turn it on

Why does my WD TV Live Hub always do the 'Compiling Media Library…" thing when i first turn it on, i just sat through it compile it all from my NAS, then to test i turned the box off (3 second power button) and when i turn it back on it shows Compiling Media Library at the top of the screen and i cant browse my Videos, Music or photos properly (have to browse folder structure after accepting the warning).

So why does it do this long process everytime i turn it on?  My wife and kids dont want to have to wait for this each time…



If you turn the hub completely off(3 second power off) it will always compile the media library, if you want to avoid this you should just press the power button shortly then it won’t recompile once turned on.


I just press the buton when I turn it off, but when I turn it on it compilling again and again every time

So Jim - are you saying yours does it even when you only put it into standby? and not just the full power off?

Also if i only put it into standby so that it doesnt do this media compile does that mean it wont see the new files i add the NAS until i do a full turn off and back on?

It never stopped compiling, it was compilling for 2 days and every time I turn it on it cuntinues the compilling

Compiling Media Library… happens if WDTV LIVE HUB finds new files in order to do content aggregation, The speed at which this takes place depends on how fast your NAS share is and also how many files you have on the folder you have shared on the network, The new firmware requires that you have your network share in READ/WRITE mode so that it can create .wd-tv folder, and create thumb files for all the image files etc; etc; 

If the unit is always displaying  “Compiling Media Library…” it means it never finished the content aggregation process of the files and folder that it found.

In order to troubleshoot this, Please stop your network share and see if the WDTVLIVE HUB can finish the content aggregation of the internal HDD first, That also depends on how much files you have loaded on the internal drives but usually seen to complete in less than 30 mins, If you really want you can also clear the Media Library and let it re-compile for the internal HDD and let it finish the  content aggregation process 

Once you are sure that WDTV LIVE HUB has stopped displaying the “Compiling Media Library…” you can be sure that nothing else other than the speed and the sheer content of your NAS share is the cause of this constant  “Compiling Media Library…”  issue.

If you power-off the unit completely either by pulling the plug or pressing the power button on the front panel or remote for more than 3-4 secs it will completely shutdown the unit and it will have to re-compile the databases again.

I agree your frustration my friend, but that is how it is designed, It does not keep track of  the list of known files it aggregated the first time, it always find the files and re-compiles again and again when resumes from a full power-off. This unit is not designed to be turned off as it was designed to be a NAS server also.

When the Compiling Media Library… is displayed the unit can be used, It play movies, browse the online services just certain features like getting content metadata information is not available…

Hope this helps

With best wishes

1 Like


hi jim

i am currently experiencing very similar problems to your good self!


I hope so.

i will post a full report upon my problems tomorrow, cos it is bedtime now and as i am so fustrated with my new WDtV live hub media player  i will not be able to make my issue clear!

BTW i really like the potential of this bit of kit BUT i have spent so much time p***ing about and reading forums etc, etc (lets say 2 days worth of f…kin around trying everything known to me) that i could have watched at least half my movie collection! Anyway not 2 worry- perhaps we can get to the bottom of this issue???

WD please advice soon upon further comm.



Hi all,

Similar problem for me.  I’m new to this class of device and installed mine on the weekend.  It’s connected to an XP PC (via EoP) that has thousands of photos and videos on it - stuff that I want to leave on the PC.

 After several frustrating hours I found the article on workgroup settings (if it’s so important for the Hub - and wasn’t required on previous devices - I’d expect it to be covered off before pg 130+ in the manual!) and now have my hub viewing some content on the shared drive.

After a device restart via the menu, the Hub started compiling media library last night.  Several hours later I went to bed with it still saying compiling.  This morning it was still going, so I switched it off with the RCU and power cycled it. Straight away it starts compiling again - I left for work an hour later and it was still going.

Is there something else I should do if it’s still compiling when I get home, or does it normally take this long?

I want to love this device but am finding lots of reasons to regret my purchase.



As I reported before, If the unit is always displaying  “Compiling Media Library…” it means it never finished the content aggregation process of the files and folder that it found… This process can take few mins on smaller library and can take a very long time if you have thousands of tiles and folders. 

Also, If the folders that you are sharing to the device changes constantly, “Compiling Media Library…” should automatically kick-in to aggregate those files and folders… May be that is what is happening to your case… The source directories that you are sharing may be changing on the fly and that is causing the non-stop “Compiling Media Library…”  displayed on your screen, If you power-cycle the WDTVLIVE hub, it will force the content aggregation from scratch… so you are back to square-one!

If you do not care about “Getting Meta-data” from the Internet, If you do not care about Movie Backdrops, If you do not care about “RESUME” playback on DVD files, you can disable Media Library, and you will never see that dreaded “Compiling Media Library…”  on your screen again!

Hope this helps

With best wishes

Thanks Vistawall,

I understood your earlier comments but wasn’t expecting any kind of compiling/indexing to take 10+hrs so (perhaps incorrectly) discounted this as an issue. 

I’ll check when I get home.  The source directories/folders are all static with no content changes at present, but there are thousands of photos in each one so it could be purely a timing issue.

Turning media library off could be a good option, hadn’t gotten around to working out what that menu option did yet!


Further news…

The Live Hub stopped acquiring some time while I was at work, but when I tried to access photos it started acquiring again.

I turned off Media Library as Vistawall suggested above, this stopped the acquiring activity.  However, after doing this I could not access photos / videos / music AT ALL, when trying to do so the “working” circular arrow appeared over a dimmed screen and remained there for 10+ minutes (I gave up at that time).

I subsequently went to the menu, and did a “clear media library” which took a few minutes, and then turned Media Library back on.  Next attempt to access photos kicked off compiling again, so I returned to the home menu and left the Hub while I had dinner.

Success!!!  An hour later compilation had completed and I now have neat and tidy display of all media content in the correct menus…no more having to navigate by drive / windows user menus / documents and settings / etc etc etc.

My only thought is that compiling had an issue at some point that the Hub failed to address, causing continual acquisition that never completes.  Maybe “clear Media Library” is a valid step if this kind of symptom is experienced?

Thanks all for detailed posts and to Vistawall for assistance.


I’ve been battling the “compiling media library…” message too now. 

I finally got it worked out.  I’m pretty sure my problem was that one of the folders I had shared on my laptop was the entire C: drive.  After I deleted that share from my computer, it finished within 20 minutes or so.

Do we have any kind of idea about the relationship between the amount of data on the internal drive and how long it takes to compile the library?

We just got our hub and I spent nearly 48 hours copying 650GB of content across our LAN consisting of:

~ 35,000 photos

~ 3,000 videos

~ 20,000 songs

It’s been compiling for a couple of hours now and I was wondering if this is an overnight kind of task or if I should already be skeptical that it’ll finish. TIA.

Update: It tried to compile the media library overnight and was still going in the morning. So, I went in and cleared out the library and restarted its compilation routine. I know it took at least an hour, but by 12 hours later (next time I checked), it was done.

Now, I’m really unhappy with how slow it is to navigate menus.  That **bleep** spinning arrow icon is going to get burned into my screen as much as I stare at it now.  Seriously, it takes up to 10 seconds just to change folder levels and there’s less than 100 items in many of these folders.

I turned off thumbnails (changed it to “list view,” I believe) and it’s a little better, but still very, very sluggish.

Is this a problem with the size of my media library, or just a limitation of the processor inside the Live Hub?  TIA.

Update: I guess the unit was “busy” when I was trying to use it that first time as these most recent usage periods don’t exhibit the UI lag I experienced. So, that’s great. Now if we could just get network write times to improve, this would be an all-around great unit.

Chuck in OZ,

    Your story is exactly whay I have been doing.

    I cleared the library and turned it off, restarted it, two 3TB drive later, and 40 mins, it was done.

I just bought a live hub yesterday, and am also very dissapointed at this seemingly deeply flawed aspect of it’s design. I am seriously considering returning it because of this. Video playback is often jerky and the audio keeps dropping out during the long compilation process. Turning off the media library seems to disable 99% of the live hubs functionality so that’s not an option.

Surely it can reserve part of the hard drive space to permanently store this media library rather then recompiling it every time the unit is powered up?

In a time when we are all being told to power things off at night to conserve energy this thing has been designed to never be switched off? Really?

Bad design decision #65467

Same issue here. I had the live hub for the last 3 days - it never stopped compiling. I have about 250GB of music and video on it. I tried to clear the library and re-compile, same thing. I see people here who are able to compile 2-3 Tb in 25 minutes, and not local even, over network? Then what’s wrong with mine? all my stuff is local and the hub doesn’t seem to be able to compile it even overnight.

ad me to the list of unhappy customers with this compiling mess.

my musiccollection contents <18000 songs 130 movies and 48 pictures.

i let it blink for over 72 hours, several times. so patience wasn’t the issue.

sometimes it reaches 6000 items in music, sometimes it falls back to zero.

i deleted and recopied the data >750GB in different ways, folder by folder (1800 folders btw),

all at once, from the pc to the hub, vice versa, and still nothing.

highest i reached was ca. 12000 items. then it restarted itself and started all over.

i seriously hate you now WD… *sigh*

Beatmaster:   Have you tried copying over in small batches, and doing a re-compile each time?

My guess is there’s SOMETHING in the contents there that’s choking the compiler.   And doing it in small bites until it chokes would help narrow down the specific issue.

My media libary has 

  Video Library:   1507 ISO files (and matching XML and JPG files) for a total of 4800 files.

  Music Library:  372 M4A files, 2922 MP3 in about 400 folders

  Photo Library:  ~21000 photos.

My Video library takes about 2 minutes to compile.

My Music library takes about 4 minutes to compile.

My Photos Library takes about 7 or 8 minutes to compile.

These are rough estimates.   But I do know it’s not HOURS and HOURS.  :)