Compilation of Windows 10 Methods, Steps and Solutions

The only place on Windows 10 that my device appears is under Settings > Bluetooth and Other Devices.

It shows my NAS drive as “not connected”, the only option is to “remove device” is this something I should try in order to try and find the device again?

Generally if one checks the steps in the initial post, in particular Windows 10 Specific Method 1 through Windows 10 Specific Method 5, that will often solve the issue of the My Cloud not being shown in Windows File Explorer or not being seen by Windows.

The other thing to check is the security software on the local PC. It is possible the firewall or security settings are blocking local network devices from being discovered.


FYI, I had the same problem as above & ran steps 1 to 5 (incl. static IP) - to no avail.

MyCloud would be “seen” by my router - but wouldn’t seen as a Network in W10 Explorer.
The “Public” part of MyCloud would appear in W10 Explorer as “PC” though.

And then I changed “WD Explorer” to “launch at Windows start-up”… and it worked…

I’m no fan at having that window open upon Windows start-up, though. But if that’s what it takes…

Good day to all…

Interesting solution. WD support had given up on trying to solve my issue. This was after multiple on-line sessions with support. They really tried but had no resolution. I finally set up my WD drive with static ip addresses and edited all my Win 10 PC’s Host files with the WD ip addresses. and it solved my problems. THIS IS A HORRIBLE SOLUTION but it works. Someone at WD needs to fix this issue.

The only thing I can suggest to to make sure you have [Enable NetBIOS over TCP/IP] in the Advanced TCP/IP Settings for your network adapter. Usually this is not necessary but under some situations this simply doesn’t work well under Win10. I use a DHCP assigned IP address (not static) but it is reserved in the gateway router so it behaves as a static IP.

That assumes the problem is with the My Cloud and not with Microsoft Windows.

If one’s router is seeing the My Cloud (issuing it an IP address) and one can see the My Cloud listed as a PC in Microsoft Windows File Explorer that would seem to indicate a problem with Windows rather than the My Cloud.

In addition to the suggestions made in the first post of this discussion, one should also check their firewall/security software. There apparently have been instances reported in other past discussions of third party firewall/security software impacting the ability to access the My Cloud on the local network.

Other troubleshooting steps are to test My Cloud access on another local network PC or device to see if the issue persists. Try connecting to the My Cloud using it’s IP address in Windows File Explorer (example: \\ Sometimes Windows will have trouble resolving local device names with the local network router.

And reports of recent Win10 updates modifying the existing firewall settings.

I have spent hours trying to figure out where my drive went after moving to Windows 10. I finally found this forum.

Am I supposed to start with the first step, or potential solution, and keep going until it’s resolved?

Since Western Digital and Microsoft both point fingers at each other and will not acknowledge this issue. I suggest starting with the first step and keep a log. After you try one solution if it does not work back it out and then try the next. Sooner or later you will find one that works.

Thank you for all of your contributions… after all of this I was still unable to see my NAS’ in my computer list.

I am running Win10 Pro on new system. I have run Plex on multiple WD Cloud NAS’s

WD Discovery sees my drives but cannot map them…Same as Win Expl

If you can open your WD Dashboard wait and read below…

After trying all of these and more from other forums, I hit the wall… Reboot after reboot after reboot with each test and win explorer not showing the network and computers in harmony I right clicked on the Network icon in the left window pane and selected “Map Network Drive”.

This worked for me so take it with a grain of salt…
Goto WD Dashboard: Settings: General —>You will see the field “Device Name” I copied it (ctrl+c)

Right click the Network Icon in the left plane…Click the “Map Network Drive…”
Select your drive from the drop down…
in the folder box type in “\the name you copied from the dashboard\public”
no quoutes and the paste should be self explaining…

check “Reconnect at sign-in”

These do not show up as connected computers nor NAS, but as network locations, however Plex can now pick it up as a mapped drive.

Worked for me,
Good Luck,
■■■■ Lowe

1 Like

You should also check the ‘connect using different credentials’ box, and enter your MyCloud username and password, otherwise Windows will not allow you to connect to your private shares; it will not allow mixed credentials for network drives.

Added a General Method 3 with the suggestion cat0w made in the following post.

This post was flagged by the community and is temporarily hidden.

Spammer :roll_eyes:

1 Like

This is a good guide. However, I spent two days attempting to connect to WD My Cloud NAS drives from a new Surface Pro (Windows 10 Pro). It took that long even though two other Windows 10 computers on the same LAN were working fine.

Here is hint for Windows 10 users. DO NOT SIGNON TO WINDOWS USING A PIN.

This feature in Windows 10 is handy, but there are bugs in the implementation. When you sign on using a PIN rather than a password, the network sub-system has trouble with the credentials. Evidence of this is the “net config workstation” command at the command prompt. You will get: “System error 1312 has occurred.”

When you attempt to “Map network drive…” you will get the following error:

Both errors go away if your log on using a password rather than a PIN.

My case may be unusual because I use Office 365 credentials to logon to my personal computers. I still think chances are good that if you have tied all the “fixes” above and do logon to your Windows 10 machine with a PIN, logging on using a password may solve the problem. It worked for me.

Thanks @lamwilli. Added the fix to the initial post as Windows 10 Specific Method 7. :slight_smile:

Thank you so much for sharing. It helped me fix problems that I have since the update of Windows 10.

VPN Sai Mannat AnyDesk

@Bennor - very commendable that you summarized all of the potential Win10 issues & solutions. I would not recommend downgrading to SMB1 only…you may as well downgrade to Windows 7 :slight_smile: There are potential security issues with SMB1 (as you noted) and performance enhancements in SMB2+. As a Mac & Linux user, I had a different set of issues so after reviewing many TCP conversations in Wireshark, I chose to SSH into MyCloud and modify the /etc/smb-global.conf file (note that your #2. Navigate to the “/root/etc/samba” subfolder is incorrect - it is the “/etc/samba” folder). Other than the Mac-specific changes, I would recommend:
min protocol = SMB2
client signing = disabled
I did not see the client signing parameter mentioned above - that was a real performance hit for Macs and may be something that would allow your Win10 clients to connect. Samba (which runs on the the MyCloud) will negotiate the highest protocol, so I don’t recommend the “max protocol” parameter. SMB3 is somewhat of a misnomer, MyCloud and the clients actually negotiate the 0x0302 “dialect” under the SMB2 protocol, otherwise known as SMB3.

Another way to sometimes access the MyCloud is through the mDNS address which uses .local as its domain…which is why you should never give your local network that domain name:

One other note: “max protocol = SMB3” is not permitted on Gen. 1 MyCloud with the latest v4 firmware. The testparm command will show what is allowed:
NAS:~# testparm --show-all-parameters|sort|grep protocol

You may want to try to limit Win10 to dialect 0x0302/SMB3.02 to avoid the “SMB 3.1.1 pre-authentication integrity” (i.e. crypto hashing).

hi all
just purchased a wd PR4100 had the same issues but what i did was update to the latest OS on the drive and then everything was visible

just a very stupid thing for me !!!

if you can get into your drive make sure its firmware fully upto date